Aeotec Smart Switch 7 unable pair second device fast blue blinking


Today I received 2 Aeotec Smart Switch 7 switches. The first switch installed just fine. After plugging the first switch in a wall socket the indicator light turned green and I could finish the setup process in the Homey App without any problems. This switch is currently working switching my TV / Receiver etc.

The second switch is not working. As soon as I plug this one into a wall socket (same room) the indicator on the switch rapidly flashes blue. I followed this Manual to see if I could manually get it out of pairing mode or factory reset it but nothing seems to work.

Does anyone know what could be wrong or I maybe could try before I contact the shop where I bought them?

Did you also try to include with the device very close to Homey?


My first attempt yesterday was at a wall socket close to the Homey. I have also tried another wall socket yesterday. I gave up wend to bed and this morning I have tried again in a wall socket close to the Homey and guess what, it worked. Iā€™m not sure why. The indicator on the switch shows in the upstairs room where the switch is going to be used that the connection quality is good. Thank you for your reply.

1 Like