Not able to pair Z-Wave Danalock V3

I have been struggling for a while to add a Danalock V3 Z-Wave to my Homey pro 2023 that now is running 10.0.3
I have been adding about 20 Z-Wave devices of various brands without any problem.
When I add the Danalock device, I get the prompt to enter the PIN.
The pin is the underlined DSK that is printed on the inside of the battery cover.
1 second After entering the PIN, I get an error saying: “Something went wrong while adding your device. Please check the pincode and try again”
If I try again and enter a random number the error is the same.(!)

The Danalock app is now version v3.2.3
The Danalock FW is updated from my phone to FW 0.21.7
The Android app version is

I have searched the forum and tried everything that I could find. This includes:

  • Reset the Danalock to factory reset, (10 clicks)
  • Using the developer tool to remove the device even if it does not appear using “Remove any device” and One click on the device, followed by a confirmation from dev tool
  • Having the Device centimeters from Homey when adding
  • Restart Homey( Not done for all attempts)
  • Leaving Homey power off for more that 10 minutes( Not done on all attempts)
  • Making sure that all Routers are reachable, Healing the two devices that now and then become unreachable, all according to the developer tools z-wave listing
  • Scratched my head…

Anyone that has successfully added one of these latly, or having a suggestion ?

Well reading all what you have done, I’m scratching my head as well.
I don’t see anything mentioned about the distance, have you tried to pair it in close distance ?

Do you have any S0 paired ZWave device ? If so, can you try to pair those again (it will require also to fix your flow, there is a script for that, just write down the device id before) - there was on SLACK recommendation to avoid any S0 encryption.

Maybe share your Homey Developer Tools - without the System Information part.

Thanks for giving this some thought…
I might not have been clear, but I have had the Danalock centimeters away from Homey when trying to add the device.
For the S0 question, I’m a bit on thin ice, but I have added all devices with the defaults, and assume that is S2 ?
Maybe what You ask for is visible in the developer Tools? I will attach a screen capture here

Hm, it looks fine, what happens if you do TEST or HEALTH on 5/9/38 ? Don’t you get ZWAVE error ? The reason I’m asking, is that you may have too many Rx packets… I hope you don’t face Homey pro 2023 - zwave too much traffic error? (also seems you had some problems because all nodes shall be or at least are in case of my devices “Last working route”) - in your case you have node 2 with route “Previous last working route” which in my case indicated always some kind of problem.

also maybe last thing to try - power of or re-plug those non-battery powered devices, restart Homey after eg. another 10min and then try to pair Danalock.

Except of that, I’m out of ideas. ;-(

Thanks again,
5, 9 and 38 does successful Heal and also Test.
I have not had any ZWave errors so far, but I have moved some of the devices around latly to try to create the best Mesh, but I find it a bit hard to do, as there is no signal strenght indication on the devices, so it will take some time I guess.

Tomorrow I will unpower Homey, and then reset( unplug/ Plug) each device, and then start Homey again. Leave it running for an hour or so, and then try to Pair the Danalock again. This full restart should reset the above statistics, so I can observe it without changing something for a while.
Again thanks for Your thoughts. It is much appreciated since I’m in the learning process here.

Hi, I did power down everything Like You suggested, but I’m still not able to add that Danalock.
I guess I will have to contact Homey on this, or is it the app developer first ?
After the full power off of everything, all the numbers in the Developer tools ZWave display now seems OK.

Yes, contact Athom - be sure to generate system diag ID and app. diag ID. Btw I checked firmware, sw version etc and have exactly the same - I have been re-pairing my Danalock like 2 weeks ago without problems. I really wonder what would be the case…

Thanks again. I have submitted a support request with reference to the two diagnostic reports.
I will make an update here when / if the problem can be resolved.

Have you heard anything yet?

I quickly got a reply where I were asked to use the non Secure PIN (00000) but that did not work either, so I’m again waiting for another solution.
Do You have the same problem ?

You could try to сontact Danalock support

In the meantime new firmware has been released also with some Z-Wave fixes… have you tried to install the latest beta/experimental?

IThanks for the suggestion and the link.
I will contact Danalock if Homey support not can resolve the issue

My Homey is now at 10.0.4 , and Danalock is at 3.2.6 This means that each have been updated multiple times. I have now and then tried to add the Danalock, but the situation is the same. I have also read the change logs for these, without spotting something that could be related.
I will check out the latest homey beta / experimental later today

I’m expecting to have a feedback from Homey the coming week as I were told it could take three weeks to get support

It’s really weird, keep us updated.

My Danalock, except of having some other issues in my case (getting stuck after unlocked, probably malfunctional gear or something but works a while after recalibration) works flawlessly with my both Homey’s & previously 19 now 23…

Btw, you have also tried to remove batteries from Danalock shortly, right.

Thanks for the suggestions
I can see that the experimental FW in the pipelane could have an effect for my problem adding the Danalock, It might not take that long before these ends up as stable releases…

I have tried to pull the batteries, but not every time, so I tried that again today, but to no help.

I will post the solution here if there is one

Today Homey were updated with 10.0.5 that included those z-vawe improvements , so I have tried to add the Danalock again. Still the “Something went wrong while adding your device Please check the pincode and try again” message

If I enter a random number PIN code the error message is 100% the same. It is almost as if my danalock has a battery cover with the PIN from another Lock. However, the box was sealed , so I find this unlikly.

I’m not sure if this would be expected if somehow the handling of a correct PIN fails. Maybe the coding is a bit weak in this area such that the error can be caused by different causes using a common error message

1 Like

While entering 00000 it should be included unsecured… so it that case it would not matter. Maybe try to contact Danalock support to validate the PIN

I tried again as unsecure and again it fails with the error “Something went wrong while communicating with the device. Please try again”

I will contact Danalock support if not Homey support get back to me soon

1 Like