Danalock V3 can’t be added via Z-Wave

I’m using early 2018 Homey 8.1.3
I want to add Danalock V3 via Z-Wave, but after entering first 5 DSK digits, I get an error.
I have removed the device from Z-Wave network before trying again, but no luck.
Danalock has latest firmware.
Any suggestions? Thanks!

Do you try to pair it in close distance of Homey ?

Yes. I even tried few longer distances, but I kept getting the same result.

Can you share view from Homey Developer Tools ?
after you had removed Danalock, did you restart your Homey ?

I restarted Homey and Danalock by removing batteries. Which page would you like to see from developer tools?


Well it’s quite empty because I just moved and I am starting eveything from scratch.
One Fibaro RGBW module is working, but at the moment it’s not plugged in.
I had Danalock V3 working fine before, but I left it in my old house and bought new one.
I have ordered new Homey Pro, but until I get it, I want to get some stuff working with old Homey. Like door lock, gates and garage door…

I’m afraid you can’t have router device disconnected when adding battery operated ZWave device - I would suggest to either plug it or remove it prior adding Danalock

Thanks. I removed the device and then paired Danalock just fine.
Good to know, that adding new devices could not work, if all added devices are not powered up.

I would say it may… but depends on the mesh route, probably some ZWave specialist would say more… so to prevent any random results, it’s always better to remove such offline devices. Great that it worked, have fun (as Athom support would say :wink: )

1 Like