Multiple Apps not installing/starting

If anyone could shed some light on my issues it would be great. I have a ticket open with support and waiting for a reply.

A couple of days ago I had an issue with the Aqara app not installing properly. It would show as installed on my HP23 but wouldn’t work. If I pressed restart it would notify that the app was not installed. Raised a ticket with support and magically later that day it suddenly worked.

Yesterday morning I noticed a couple of Zigbee devices had gone offline so I restarted the homey and when it booted up I found that not only did the Aqara app not start, neither did Amazon Alexa, HomeKit controller, INNR, MQTTBroker. These apps could not be restarted notifying that they are not installed. Tried to re-install them but still no joy.

I didn’t have a backup so couldn’t restore to the working version (backup subscription now purchased).

Is there any logs that can be seen to see what happens when the system boots up?

No, unless you jailbreak your Homey.

I already posted in your other thread about this issue that others are also having issues. There’s not much the community can do about that as it needs to be looked into by Athom.

1 Like

FYI the cloud backup only saves pointers to your installed apps. When restoring a backup, these apps are getting downloaded from the app store and installed.
So, this would not help in your issue with malfunctioning apps.
But, nonetheless, automatic cloud backups saved my ass more than once😉

When you create a local backup, restoring it would put your complete system in the state of the time the backup was made (AFAIK).

Thanks for the info. That really puts a question on the usefulness of the online backup system.

Looks like I’m going to have to factory reset and start from scratch.

I get your point
It’s most probably a ‘clever’ way to save traffic and storage cost.
But this is NOT clearly communicated up front, which is a pretty bad practice.
The last sentence in this quote implements regular apps are backed up (the way I read it that is):

Another specific disadvantage:
when you’ve stopped updating an app to keep functionality which is removed in newer versions (f.i. Athom’s tado app lost it’s geofencing function), you will lose it while the current stable app gets downloaded and installed.
When you’re lucky there’s a github/bitbucket older version repo which you can install per CLI

But still I am very happy to spend €10/y for the backup service, while I would have been forced to start from scratch otherwise. Which will cost me many weeks.

But, I have to say I never read about of this weird app issues before, the last several days some users started reporting similar issues.

And Athom made 1:1 backups possible for the Pro 2023, which is a big step forward.
With one major downside: Homey has to stop running during backup creation, and it cannot be done per LAN.

Well, a bit of an update. I have managed to get it up and running again BUT I still can’t install some apps.
I tried a factory reset on the homey (not the USB connection) and set it up as a new device, not restoring from a backup.

To my surprise, the first app I tried to install (Amazon Alexa) did not install. Same issue as before - looked like it’s installed but when I pressed the restart app button it pops up to say it’s not installed. I honestly expected starting from scratch would work.

So, I tried the factory reset using the USB connection. First time I’ve done this and it is very obvious a different reset type as it took quite a while to complete. This worked, I installed the Alexa app and all was well.

Out of curiosity I did a factory reset again from the homey and this time asked it to restore from the online backup - every thing came back online and all apps working and my flows started.

I did notice that my timeline was showing an problem with the MQTTBroker not starting the broker with an error. I checked the settings and they looked correct but the broker wouldn’t start. So I uninstalled the app and re-installed it. And - back to the app not installing properly. So frustrating.

So out of curiosity again I uninstalled the working Alexa app and tried to re-install that, and again, same problem. So, another 30 minute reset using the USB method and I’m working again (apart from MQTT).

Looks like I can’t risk installing apps at the moment in the fear of having to go through all this again. When support finally get back to me maybe they can shed some light on it.

Give them a few days then I think I’ll just send it back (only had it 3 weeks) and start again with HA. Shame, really like this when it’s working.

It’s a really odd issue I’d like to say . Homey is not perfect, but which domotica controller up to € 400,- is?
Btw I have HA and Homey running, and I love this combo. HA for super device support & zigbee, Homey for the automations, 433MHz, IR, Ble.

And also HA is not free of issues, f.i. a zigbee2mqtt update killed my complete mesh. Took me days to get everything right again :stuck_out_tongue_winking_eye:

1 Like

Well - another twist. Noticed that the Tuya Zigbee app wasn’t installed, must have removed it before the backup. I installed it and no problem, except it was the wrong version I needed (I was using a test version for the device I had). So, installed that one - it didn’t install, same issue. But, the release version will install. Very strange.

So, this morning I decided to do a full factory reset by USB again and to start from scratch. This time, the first app that worked yesterday when I did this (Amazon Alexa) did not work, subsequently the other apps didn’t install either. There seems no logic in this whatsoever. I did exactly as I did yesterday and it worked but today it doesn’t.

Just doing a restore again to see what happens.

Which suggests maybe a hardware issue.

Still haven’t heard from support yet but out of curiosity I took the homey in to my office today and plugged it in to my studio hub (A BT broadband Hub) and to my surprise the apps that wouldn’t install, now did.

Got home, plugged it in to my home network (an Asus mesh system) and they wouldn’t. As I’ve said before, some apps do install and some won’t.

Does anyone know of any network requirements, ports open or anything that you think may interfere with app installation process?

For the time being I’ve got all the apps I need installed and turned off auto updates on all apps and the system.

I never changed anything @ standard provider router, so, no.
But try temporary disabling any Pihole, Adblock, any network influencing tool, special DNS settings and so on.
Also check if CGNAT is enabled by your home internet provider; if yes, request for disabling it.

That’s always a good practice imho.
To monitor available updates, you can install (… if it works that is…) the App Version Checker if you like.
It’s available @ the re-invented Homey Community Space store:

Hi, I have the same issue! My homey restarted this morning and after that the Meross app said it had crashed and I couldn’t restart it.

I uninstalled the app to try re-installing, app appears like it’s reinstalled (but missing logo icon) and there’s not app settings option, hit restart app and it says app not installed.

I randomly tried to install two other apps one did same thing and the other installed fine. I’ve not managed to get it working and really don’t want to do hard reset, I’ll raise a ticket with support.

I wish you all the luck with support, I’m not sure they actually exist.