Mi.Light app

Is there any news on the update of the Mi.Light app? A lot of my lighting is controlled by this app and it will stop me from upgrading to HP if the app is not udpdated.

It won’t be updated sadly. Athom has pulled the plug on that app. Won’t even be upgraded to SDKv3

When you don´t sell your white ball:
You can use the Homesh app set, then you’ll be able to keep Mi.Light running on the white ball as it is now, BUT you can control it using the Pro 2023.

Another thing you can do is actively look for a new developer/maintainer for the Mi.Light app.

I assume Athom would be so kind to transfer the app instead of just leave it be.

N.B. what is the homey.app store URL of the Mi.Light app?
Can’t find it.

1 Like

It seems to be removed from the Homey app store, but I have this url for you:

Ah I see.
It’s odd the developer in the store is Marco den Otter, but the source code developer is Robin Bol (Athom bv).

One can fork that repository, and upgrade the app to SDK3 and then CLI install the app.

Hello MiLight users, out of desperation I decided to rewrite the repository of the old MiLight app to make it works with SDK3, took me some time but at the end I finally did it and published it :slight_smile:
I forked this repo which was more up-to-date and easier to convert : GitHub - HVerkiel/com.milight

Git it a try here et and let me know → Mi-Light Appli pour Homey | Homey

Cheers !

It is updated to SDK3 now.

I have installed the app Mi-light SDK3 and ahve problems. First installed the new app on the old homey pro 2019 and it worked fine. Then everything was transferred to the new Homey Pro 2023 and it worked fine. Then I kept getting network request failed when switching on the lamp.

Very happy to report,

I can switch ( at least the color white ) on my ancient MiLight setup with a first gen. mi-box via this app v 4.2.8 on the Homey Pro 2023.

Massive thanks to Vincent Steenhoute creating this app ! ( as was about to replace all milight stuff ! )

I had or installed the Mi-light app from Vincent. When i switch the. Lamp on I got the message “network request failed” and 30000 ms. When i restart the app it’s working after then i switch the lamp on i got the same message. I have already the router switch to 2’4 ghz but even then i got the same message. Have someone somebody a resolution?

Hello Ben, I was off my house for some time off :slight_smile: I’ll be back next week to look at the errors all people are facing with this current version. From the debug error I’ve received, seems like the app may be lossing the bridge IP address. In your network, did you set a static IP address to your milight hub ? If not I recommend to do it.

Thank you for your commitment to the Mi-Light app. Everyone was happy that you converted the app to SDK3. Both I and others thought that we would no longer receive a response. Fortunately, you responded and many people will be happy with this, just like me. You still have some time off in the near future. Enjoy it and we will wait patiently. I will take the settings you recommended to heart and apply them. If it doesn’t work out, you’ll hear from me. My thanks again

I’ve been a Homey Pro user for only a couple of months and the only part of my setup that I couldn’t bring with me (from Homeseer) was my Mylight bulbs. I bought some Tuya bulbs instead but now I’m hoping I can return them to Amazon and stick with Milight!

Thanks for your work on this - I’ll be trying it out on my setup in the n3xt few days and will give you feedback.

I’ll just add that the bulbs themselves do seem to be good quality. I’ve had few problems, the spotlights GU10 and MR16 are true spotlights with a narrow beam which creates pools of light, and all bulbs are quite bright even on dark colours. I’m keeping my fingers crossed that it will all be good!

Hi Vincent, greetings from England’s Lake District. An update on my progress. I’ve reinstated a number of my Milight MR16 spotlights and so far everything is working well. They respond very quickly - instantly - to an instruction sent from your app. I have had no disconnection issues.

I use the Milight box version 1 and the bulbs are Milight FUT104, 4 watt, 12 volt, RGB+CCT. I’m currently using 2 of the 4 zones.

Hope this feedback helps. Thanks again for taking on this project.


Hi Vincent. I have given the bridge’s Mi-light a static IP address as you recommended, but the problem still persists.

Me too!!

Ok thanks for the testing, indeed does not seem to fix it.

I’ve looked deeper today and it seems the app somehow loose the connection with the bridge. During my tests I’ve seen also than playing with color selection may crash the connection as well.
To try to solve this issue, I have first updated the dependencies (onecolor, homey-log and node-milight-promise) as I don’t yet see bugs in the main code. You should see a updated app with version 4.2.9.

let me know if it helps.

BTW if you still have issues, please share you milight setup like @Chris_Starkey.
On my side I’m using a Milight Box v2, with 3 zones containing 1 FUT038 bulb to control led strips.
So if Chris do not have issues, the problem may be related with bridge v2 and higher.


It works again.
Thank you verry much.

Hallo Vincent. Thanks you are great :+1: Gelukkig werken de knoppen van de aan en uit weer. Thanks. Alleen de veranderingen van kleuren werkt bij mij niet. Wat ik verder ook zie in de menu van kleuren van de RGB Lamp dat ik de kleuren pallet krijg van de warm/white lamp. Verder kan ik hier niets in regelen. Reageert niet. De volgende setup van Milight heb ik. Mi-light Wifi Ibox 1, MR 16 FUT 104, FUT 025 2,4G RGB LESTRIPS, FUT 10A 2,4 RGB LED LAMP, FUT 08C 2,4G LED BULB WARM/WHITE.