MEROSS MSS315 Matter not pairing

Hello everyone,

i tried this week to pair the brand new meross MSS315 matter plug, and it’s not working, I end up with this error all the times :

I tried the pairing process from the homey app, it recognizes the device nearby, ask me to choose a name, tell me “devices” added to home and then this error.

The device is pairing correctly to HomeKit, then I tried to generate a paircode directly from homekit to link the plug to homey this way. Same issue, not working at the end of the process.

My homey is only connected with ethernet and I saw the plug is WIFI based protocol (not thread)

Do you have any ideas ?

See ya
Alexis

I dont see support for this device in the Meros app. So you should ask the developer to add this device(if possible)

Matter support doesn’t depend on the app.

1 Like

The device being paired with HomeKit might be the issue.

Thank you for the answers.
@Ria_Banis this is a matter device so it don’t rely on the apps.

@robertklep the fact is i tried both ways :

  1. Homey → Meross by scanning the matter QR code from the Homey IOS App

  2. HomeKit → Homey → Meross Plug by scanning the matter QR code from the homekit app and clic on the plug device to get the matter pairing code, then go to HomeyIOS App to add new matter device and tap the code i just get from HomeKit

From homekit directly i can control the plug, but it never add in the Homey IOS App

Here a gif with the first steps from the homey app
by_homey_first_steps

here another gif with the end of the Homey adding process and the error
by_homey_last_steps

Sorry i can’t bring the two image in one unique post because im new on the forum :stuck_out_tongue:

Have you checked the support article?

Don’t know which smartphone do you use:

Yes of course, i started with this article.
I use an iphone 13 pro;

Please have a look at this post (German language). After an update of the Meross plug he was able to connect it over Matter with Homey.

Ty for the reply, i checked out this comment :

Kurze Rückmeldung:
Meross hat ein Firmware-Update für den MSS315 veröffentlich. In Version 9.5.33 wird ein Bug mit dem Matter-Binding behoben. Danach konnte ich die Steckdose mit Homey verbinden und kann diese jetzt An-/Ausschalten.

In Meross App, my plug is marked as up-to-date with 9.5.31 version number

I don’t use any Meross devices, so I don’t know if there is something like an experimental firmware available like it’s by Homey the case. Maybe ask the post writer for help.

Hi @AlexisC ,

I checked it in my merls app. It’s 9.5.33 for hardware version 9.0.0. With 9.5.31 the matter pairing process won’t succeed. Maybe you know about this website? There are some hints to get it working:

Greetings,
David

2 Likes

thank you for your answer and the link.
I followed the steps but, no firmware update avalaible in my meross App, still in 9.5.31 :frowning:

I was able to pair it with Homey Pro early 2023 using Matter (without the Meross App for Homey). Firmware of my MSS315 is 9.5.33.
Unfortunately, there is no report of any energy consumption. Similar to what I’m experiencing with SmartThings. I contacted Meross support and waiting for their response in order to know if I should return them or not.

On a side note, I was unable to pair my MSS315 to Homey using the multi-admin feature after I connected it to SmartThings and used the shared code.

Have you received any response from Meros’ support