Issue pairing a new Zigbee device (Lixee power meter)


I am new to Homey and really enjoying it so far. Though I am in a very frustrating situation.

I am posting a question here because after several attempts and several research on this forum and more widely across internet, I cannot find any solution to my issue.

I am trying to pair a new Zigbee device, a Lixee power meter, to my Homey pro 2023, but I have never been able to do so. The device remains in pairing mode (LED blinking) and the money app (both web and mobile), ends up failing in time out (pairing took too long).

I have made sevrer douze attempts and try all the item below:

  • restart my homey
  • plugged unplugged the Lixee device
  • put the Lixee device in pairing mode before, at the same time and after putting the Homey in pairing mode
  • uninstall / re-install the Lixee app
  • move the Homey device very close to my Lixee device
  • deactivate my wifi network (to avoid potential interference)
  • remove all my other Zibgee devices (I had connect 5 others so far with no issue, mostly Aqara devices)
  • try to pair usine the standard Zigbee technology from the mobile app (I could not find this option web app)
  • try to pair the device as another device I had already successfully paired (e.g. an Aqara motion sensor P1)

I do not know what else to try. Some people mentioned to update the Lixee device firmware but I do not the equipment nor the competency to do this.

Would someone have any other advice on any other thing that I could try?
Is there any way to see logs or better troubleshoot what the issue could be?

Thanks a lot in advance for your help!

First of all, welcome to the Homey Community!

To make sure you are aware of the forum rules, please read the Welcome to the forum! post here.

Hi Jeremie,

There is a separate topic in French for the lixee app. From your name I assume that you are French, so I recommend that you ask your question in the corresponding topic.

Thanks fantross for your prompt answer.

The topic that you mentioned is Cleary part of the one that I have been duly reading.

Being new to homey I am wondering:
Wether the issue is about the Homey app, hence it would definitely fit with the topic you mention, or if it is a Zigbee protocol / device issue, not related directly to the Homey app.

Based on your experience, what is your view on this?

I am asking this question because the issue is not about the information I am getting from the device, but with the pairing itself.
As said above, I have even tried to do a simple Zigbee pairing without using the app, and it also failed in timeout.

Thanks again :wink:

Because you wrote that you had no problems with other Zigbee devices, I guess it may be a problem with the app. That’s why I referred to the Lixee app topic.
However, I don’t know the Lixee app, I don’t have any Lixee devices and I don’t speak French.
You have also already done a lot to solve this problem, which is very rare, by the way. I guess the Lixee power meter isn’t a battery device, right?

You can also try out the following things:
– Install the test version of the app

“You have also already done a lot to solve this problem, which is very rare, by the way” => I tried to do as much as I could before bothering the community ;-).

“Lixee power meter isn’t a battery device, right?” => No. It is plugged directly on my official electricity meter from the electricity company. It is using a dedicated port on it to gather electricity consumption data. This same port is powering the device.

Thanks a lot for the link to the test version of the app. I’ll try to have a look, as well as to the PTP.
What I find strange is that I can even not pair it as a simple Zigbee device from the “technology” part of the mobile app :-(. To me it sounds like it is excluding an issue with the app, but I might be wrong!

I am also thinking about trying the “reset network” in the ZigBee developper tool of Homey, but I would want to avoid having to pair all my other devices a third time… Well there is only 5 but still.

Adding more info, for other people who may face the same issue.

I have tried PTP, but it did not fixed the issue.

I have reset my Zigbee Network using the developer tool.
I was initially on channel 25, I ended up on 15 but it did not worked neither.
I have also tried with Chanel 20, but still the same issue. Homey is waiting, the device is blinking (waiting as well) and at some point homey gives-up (timeout).

Homey version is 10.0.8
Zigbee firmware version is 7.2.2-0

It’s called Homey generic zigbee, and it only (should) support devices which can be turned on/off, and for lights dim and color can be set.
A powermeter needs it’s own app.

So, if the Lixee app does not support your power meter (to me this is most probably the issue here), you can request for support at the developer,, or buy an other, Homey supported, power meter (like wifi operated Shelly 3EM WiFi-operated 3 Phase Energy Meter and Contactor Control)

That’s right, but it should be possible to add the device as a “Generic Zigbee Device”, even if it doesn’t work properly. That’s why I now also think that it’s a problem with the pairing process and has nothing to do with the app.

@Jeremie_Le_Roy, have you ever tried to reset the Lixee power meter?
Do you have any technical documentation for the Lixee power meter? In English please… :wink:

Thanks @Peter_Kawa and @DirkG for your reply.

I agree that “Homey Generic Zigbee” should not solve my problem, I was not expecting my device to work properly with it. I was trying this to see if the issue was with the app or the pairing process.

There is a reset button on the device. IF you hold it for 10 sec, the device reboots and puts itself in pairing mode. The led turns off for a few sec (pretty short) and then turns on again and blinks (waiting for pairing process to complete).

The device is quite well documented, but it is all in French sorry.

There is no other reset option.
The other option is to make a firmware update through USB, but it requires an additional (which I do not have), maybe welding as well (not sure about that, but last time I have been welding was at school and I was pretty bad at it ;-)), and usage of admin / command line tools that I am not familiar with (and I am not sure there is a Mac version, it seems to be Windows based and I don’t have any windows device at home).

At this stage I think that I will liaise with the vendor to see if the device could be defective (i.e. get another one), or send it back to get my money back.

The shame is that other people seem to have face the issue, but in the end it had randomly worked for them at one point. Other people are able to pair the device homey with no issue. But in may case I have tried more than 30 times, and reinstall all my Zigbee devices 3 times already. Time to give-up I think :frowning:

In the end I have returned the device and have received my money back.

The device does noes seem compatible with the Homey 2023.

I find this weird, as I have other Zigbee devices. I thought this was a standardized protocol, so it is unclear to me what could cause such a pairing issue.

As anyone knows a good power meter, compatible with homey 2023. which is easy to install (no strong electricity skills) and can easily capture the consumption of my all home at once? I am currently googling for options, but I would like to make sure that my next choice will be compatible with my homey this time ;-).

Thanks a lot!

It is, more or less. I don’t know how it works with other smart home gateways, but an extra app has to be programmed for the Homey so that all the device’s functions are supported. You can compare this to a Windows PC, if you install new hardware, extra device drivers must also be installed.

The easiest way to monitor the consumption of the entire house is to use a device that must be installed at the electric meter. However, which device you can use depends on which country you live in and which electricity meter is installed.
Here are some apps which supports some power meter:

(No claim to completeness)