[HOW TO] Get started with Tuya cloud

Do you use the mobile app Smart Life or Tuya Smart?
The latter works in my opinion best with Tuya Cloud **.
Is the selector at the bottom of the Tuya Cloud settings screen set to the right app (Smart Life or Tuya)?

** ) in Dutch:

Hello

Use the Tuya smart app, in the selection box below tried smartlife and Tuya about 10 or 20 times ( Each time restarting the Tuya app on the Homey ofcourse) no change what so ever.

Only thing i still can think of is;

I registered the Tuya user ( Tuya smart app) in the netherlands , now i am using it in hungary. But even that i changed in Tuya , tried changing my location to hungary, tryed in the Homey config 31 for netherlands but also 36 for hungary, with location in hungary checked with 31 and 36, and with location netherlands tried with 31 and with 36

Not much more i could think of, is there nowhere a debug / log file that i can check ? I mean the only thing i see is configure the app and thats not much to go on…

Harry

I’ve no experience concerning the effects of location changes.
Of course the country has to match on both apps.
Is it set to Hungary in Tuya mobile app?

I’ve checked the data center for Hungary, but that’s Central Europe as well.

About logs:
You can generate a diagnostic report via …More>Apps>Tuya Cloud and hit the sprocket (top-right).
Enter your username and copy the returned key.
Post a message in the official app topic, ask Jurgen if he can take a look at it for errors, and paste the key you just copied.

I see the app says netherlands, can’t change it, when i registered i was in the netherlands , no idea if there is an IP check on the location

Put my Tuya cloud account also on the netherlands so they do match

Will send him the debug file , hopefully he can find out what the issue is, apart from this everything is running like a charm

Harry

Okay. It’s odd you can’t change your country (but you can change the timezone though)
So I also think the country number in Tuya Cloud should be 31

Do you have enabled these Service API’s?

Yes

All are enabled ( and some more )

Harry

1 Like

If you are using the stable version, try the test version. This version shows the Tuya error message when pressing save on settings page. The test version is not put to stable because of 2 reasons. 1, the old API is depricated in this version. 2, I have to do extra work to comply to new rules to publish to stable again. At the moment to busy to do this.

1 Like

Hello,

Thanks! Trying it now!

Harry

Hello

I get an 1106 permission denied

Harry

Username (=email address) and/or password of Tuya cellphone app aren’t matching, according to various posts:

Try changing the pw temporary to something simple, say, 12345 on the mobile app.
If you still get the ‘1106’ error, the email address is not matching.
You can change your email address as well in the mobile app, if needed.

One day it’s going to work, Harry!

Yesssss!

Working! No idea why…. Retyped the username and password about 10+ times!

But happy now :wink:

Thanks for all the help

Harry

1 Like

Hi Harry,

I have exactly the same issue. I have done all the settings on iot.tuya.com, can see my devices, have set the id and key in the Homey’s app but still have the message “Please configure the app first”.

Could you please tell me what you did to make it work ? Did you changed your password as suggested by Peter ? or did you only tried to re-set your e-mail and password again and again into the app ?

Thanks,
François

I guess he entered it correct the Xth time :grimacing:
Try this, François. You can always revert to the ‘live’ app if you’d like

Hi Peter. Thank you, I will give a try and tell you.

François

1 Like

Hello Peter.

For information, I didn’t need to try the beta version of the app. I was going to do it but before I tried one last time to retrieve the list of my devices via the current app, with the settings made a few days ago (telling myself that maybe it just needed a replication time) …and it works, more than 24 hours without having changed anything either in the app or on the tuya site, and it works!

anyway thank you for your help.

François

I’m glad it is functioning now. I’m not aware of a ‘replication time’; from the moment my credentials were entered, I could add my devices. I didn’t use the ‘Legacy’ ones.
~Peter