[HOW TO] Get started with Tuya cloud

You wrote that, but this Tuya app is also for wifi devices.

K. How did you add the first “half”? If you add a new device again, doesn’t “the other half” pop up?
Just a guess

The cloud app probably doesn’t support the second dim functionality. You can use scenes to control the second channel. Homey API supports for single channel a lot out of the box. For second channel the developer has to create this self. Besides that it cost more effort, I don’t own such device and can’t debug the functionality.

I’ve installed the experimental app, but in the Homey app settings its asking me for the API Access ID and Secret. Does anyone know how to find those? I’m using the Smart Life app on iOS with a regular email + password account, I couldn’t find the details in the Smart Life app.

Edit My apologies @Datageek
I mixed the descriptions up :blush:
The TuyaApi, Key and ID of the ‘green’ Tuya app with the Api access ID and secret of the ‘red’ Tuya Cloud app.

You’ve installed the other Tuya app.
The Tuya Cloud app is called exactly Tuya cloud in the store :wink: and the opening topic even provided for a link to it.

Please see screenshot below. It’s v0.1.3, installed from the /test page.

[App][Pro] Tuya Cloud - Apps - Homey Community Forum

1 Like

Hello.
Im trying to add tuya wall switch. But when i go on homey to + add device and then tuya cloud, 1 gang wall switch, it sais first configure the app. But in configuration i set username , password. Only api and api password i set it randomly.

1 Like

im trying to get this app working since yesterday but I need to fill in an official API acces ID and Acces Secret. Anyone got a clue or is this since the update?

It’s all explained in the opening post of the official app topic:

It really is explained there. Screenshot from the opening post:

OK I got it working on my set up with the Tuya IoT dev account linked to my Smartlife account , but it took a few tries as it wasn’t working at first.

The thing that caught me out is the datacenter location for Tuya Cloud project has to be the correct one for the Smartlife account region, but the correspondence mapping on the webpage is out of date, and the correct mapping is not intuitive. In my case my Smartlife region is “Isle of Man / United Kingdom”. So Tuya datacenter should be Western Europe, right? Wrong! It only works with Eastern Europe (the device list wouldn’t populate otherwise).

Hello,
I am really sorry … but I don’t get it. I’ve read the information provided, but where do I get “official API access ID” and “Official API Access Secret” from?
I can’t find anything in the Tuya app nor on Tuya website if I log in “https://myaccount.tuya.com/

I’d be really nice if you could tell me where to get that.

Regards
N Hof

Try the official topic of the Tuya Cloud app.

For most apps, this info can be found at the bottom of the app page:

Thanks … I ran through it again and got the API key and secret and all that. Entered it and … tadaaa … NOTHING works anymore, including the legacy stuff. Of course there’s absolutely NO error message, besides “temporarily unavailable” when you click on the devices in Homey.

So again: Everything is entered, including Key and Secret, e-mail and password are correct. The add-on should use legacy and new and this is correctly selected in the app. Why does NOTHING work then? What could be the issue?

[EDIT]: Okay, for some reason, I had to retype the password, then it worked … but here’s the next issue: When trying to add a new device (new method), it says “configure first” … IT HAS BEEN CONFIGURED!!! FFS can’t the addon PLEASE be more explicitly, like telling me what the f… is actually the problem?

I mean if it needs the password again, why doesn’t it say “retype password” and if it needs something else before I can add devices, then it should tell me what it needs!

[EDIT2]: alright, heere we go … thought there might be an issue with the secret … so I retyped that, too … and et voila … fucked up the app again … can’t control the legacy devices again … is it possible that I need to choose? New way OR old way? the app suggest it can handle both at the same time … doesn’t seem so …

I understand your “tone” if you bought the app from a company and paid €100,- for it.
I know it’s not the easiest setup, but at this moment there’s no other way to connect with Tuya.
Please keep in mind, the app developer Jurgen is an independent Homey user, who developed and works on this app in his spare time. You can use it for free. How about that?

He was forced to add the official API to the app, while Tuya corp. is busy changing things.
If he didn’t, you (and other Tuya Cloud users) end up with a dead app.

About your struggles:
I’m very sorry, I just followed the instructions and it works fine with my Homey.
Did you perform the QR code action?

You should be able to enter the legacy account user & pass by selecting “Use legacy only”.
Restart app.
If you didn’t change your email and/or password, all your devices should be present.
Use the same email & pass as with the Tuya mobile app.

If all’s fine, enter your officiap API key and secret, en select “Use legacy and official”
Restart app.
Add a new device (non-legacy ones).
If a "configure app first’ notification is shown, your API key or secret or both is incorrect.
If you like an other error description; there’s nothing you can configure but your credentials. So…

This is default for the legacy api since day 1. Tuya doesn’t sync more often than 4 or three times an hour. YOU JUST HAVE TO WAIT A BIT
The dev has no influence on the decisions of the Tuya corp.

From the dev in his own words:

1 Like

I am a new user without an access code to the Homey app yet. I’m thinking of getting the new Bridge to get started.with Homey. However, I read that the Tuya app only works with the Homey Pro device as it’s a community supported app which is not usable with the Bridge.

Is there any way of connecting my ZigBee and WiFi Tuya devices and sensors to the Bridge? Or do I have to buy the fairly expensive Pro which I’d love to have but it just feels too expensive for the moment.

Wifi Tuya devices: not at the moment.
If yes, no bridge needed here by the way, just the beta app. It’s cloud to cloud connected.

Zigbee Tuya devices: lights and sockets can (in theory) be controlled (On/Off); for lights there’s only additional dim functionality, no color options.
No app needed, u can use build-in Generic Zigbee device.

Hello

New to Homey

Installed the tuya cloud app, filled in username / pass

API ids

31 as country code, selected central europe datacenter

I keep getting please configure your app first

Reset my password several times, its 100% correct
Restarted the app several times

In Tuya cloud under my project i can see all my devices, how can i get it connected to Homey ? Any ideas? Checked everything over and over again… is there a log or sonething that i can check to troubleshoot?

Harry

Probably your API key and/or secret input error. I don’t think it’s pw related.
Having your devices present on the Tuya cloud project is good news, that’s the hard part.

Did you copy/paste the API Key & secret? Check for leading and/or trailing invisible whitespaces, please, by using f.i. “select all”

And if applicable: Did the first character change into a capital maybe?

Email field: Did you use your Tuya smart email address, and not the Tuya IoT one (if different)?

.
Maybe this is helpful:

1 Like

Hello

Wish it was that. Already copy / pasted both around 10 times… no difference unfortunatly, in Tuya cloud everythings seems fine, just can’t get it connected

Harry