Homey Community Forum

[HOW TO] Get started with Tuya cloud

Homey can control certain devices over Tuya cloud services as long as it’s correctly set up and Homey has an internet connection.

  1. Install the Tuya cloud app on your Homey (Tuya cloud | Homey)
  2. On your phone, install the TuyaSmart app. Create an account and sign in.
  3. In the Homey app, go to More, Apps, Tuya cloud, Configure app. Enter your username and password, along with your country telephone code. No “+” or “00” necessary, so for Sweden I just type “46” (without the quote).
    Remember to set “Business” to Tuya if you use the TuyaSmart app, or SmartLife if you use that app.
    I had to toggle between SmartLife and Tuya some times to get it in order, pressing save in between.

To add Tuya devices, follow these steps:

  1. Open TuyaSmart app and go through the adding procedure (usually involves toggling the unit and setting TuyaSmart to scan for new devices).
  2. Open Homey app and go to Devices, press + to add. Choose if it’s a Cover, Light or Switch (that’s what supported by the Tuya cloud app so far). Any devices that are available in Tuya and not yet added to Homey should be available.

To add Tuya Tap-to-run scenes, follow these steps:

  1. Open TuyaSmart app and create your scene; press the plus, select Launch Tap-to-run, Run the Device, choose your device and set it up as you like. Give it a reasonable name and press Save.
  2. Open Homey and create a new Flow. Set what start conditions you would like, and in Then: scroll down to Tuya cloud, Trigger a scene, Select an object and your Tap-to-run scene should be available there.
5 Likes

Hi,
I followed each step and tried both settings for the type of app, but no device is added. Also there is no log, so I have a clue if everything is etup right. What can I do to make this app work for me? Any advice?!

Hi!
So nothing happens when you add a Tuya device in Homey? Any new devices that are available on tuya but not yet added to Homey should be possible to add.
Does the device work in Tuya app?

Hi,
Yes, it works great in the Tuya app. I even tried to delete the device and added it again in Tuya app, but the device is not noticed by the homey app.
I also tested my credentials to be sure, that is correct. But I noticed that the Logon is not verified in Homey, the message will not tell if the Logon is right or wrong. But I am sure I entered it correctly.
BTW, thanks for the app and your early reply, nice!!!

I installed the latest experimental version and now it works like a charm. Thanks for your help!!

1 Like

Hi dear, I follow exactly this istruxtions, inntuya everything its working great, and in homey after I configure the app, when I add a new device, its well recognized from homey, but when appear in the list of the devices, its unvailable, I saw it, but with red triangle on it.

Any help?

Tks

Just wait for 10mins.
That’s because of the limitations of the Tuya API used.

Do you think after I wait 10minutes everything will be normal? I ahve 2 homey pro, one on a boat and one at home, the once at home work with tuya, even I have to restart it aometime, but the once on the boat no.

Anyway I will repeat the setup and will let you know.

Tks and have a nice sunday.

Matteo

YW!

(That’s what I wrote indeed)
When you see the red triangle right after adding a device to Homey: yes. Because after 10mins the Tuya cloud is synced, and after that the Tuya cloud app can communicate with the newly added device.
The Tuya company applied this limit, not the Tuya Cloud app developer :upside_down_face:

Homey needs an internet connection for Tuya Cloud app to reach the Tuya servers.
On a boat I recommend zigbee lights, f.i. Ikea Tradfri. Zigbee is a local protocol, no internet needed.

Hello
I’m having a problem with adding my Tuya Devices to Homey.
I followed the steps but still only get “No new devices available”.

Which type of devices?

I’m having same problem with adding my Tuya Devices to Homey.
I followed the steps but still only get “No new devices available” Have LED Filament Lightbulbs. Any solution?

@SunEast, @a6lex did you create a real account with your email address (and NOT the “logon with Google of Facebook” option)?

1 Like

Thanks for replay! I use tuya smartlife app and created first with Google logon, but changed passord so now i log inn with user and password. Maybe i must create a new account then, without using Google logon in first time?

YW! Yes you have to create a new account with an email address and password. Do not use Google/Facebook login.
Using a Gmail email address is allowed.

1 Like

:smiley: @Peter_Kawa YES It worked! Thanks for your help! Registered a new Tuya account, connected the lights to the new account, and then they became visible in Tuya Cloud and can import the devices.

But … A red triangle :small_red_triangle: appears on the lights, and it says when I press it that “temporarily unavailable” I can turn lights on and off in “my.homey.app” in the browser on PC, but not in "homey the app on the phone "(iOS) Something I do wrong?

I have waited for 30min for tuya api to synchronize, but will check again in a couple of hours

Sorry for all the editing. Now it works after I restarted the “Tuya Cloud” app :slight_smile:

1 Like

Quick question - I have the IDs for my devices (I grabbed them all when I was working on an Octoprint setup), but wanted to ask - is a connection to the internet required for this or will it work over local network?
The description of the app implies it still connects to Tuya Cloud, but if so I’m not sure the value of this over the other Tuya app?

EDIT. Think i’ve confused my apps and I’m asking about the TuyApi, not TuyaCloud