[HOW TO] Get started with Tuya cloud

I have 2 lamps registered in Tuya app. Yesterday evening they worked fine with homey.
Normally when I put on the alarm, I switch the lamps off, but this morning I saw they were still on. So tried to switch them manually off via homey, but it wasn’t working anymore.

I removed my lamps in homey and tried to add them again, but i got the message please configure the app first
I then removed the app once from homey and re-installed, but when trying to add the lamps again, I got the same message.

Cloud project is defined, app is configured and everything was working before today without any problems.

Update1 : Installed the experimental tuya cloud app and no error is shown when saving the settings.
Update 2: Tried with smart life app and still get the same error

Does anyone have an idea what the problem might be

Problem solved: I had extend my Tuya API service for 6 months. Now it’s working fine again.
Thanks @Jurgen_Heine

How much it cost you for 6 months?

Don’t pay, just extend the free trial period each time

1 Like

I am having trouble generating sign code for API request in flutter. Can you help me with that.

I added a Tuya gateway, to Tuya Smart mobileapp.
I added a Siren to the Tuya Gateway.

The gateway and and siren are visible in Cloud development webpage (im using computer, not phone).

I have no errors in Homey after adding Api key.

Question: Can i add the siren or gateway to the Tuya Cloud Homey app? There is no siren or gateway to choose from.
Any suggestions?

Ah, I think i managed. The homey flow activates the tuya flow. :slight_smile:

After reading all topics I’m still stuck with the 1106 error … :frowning:

In Tuya deleopment I can see all devices and the linked Tuya app on my phone. I allready reset the password several times, now the app and the development password is even the same but still no luck.
What else can I try ?


Maybe this helps. It is clearly a user/pw issue:

Brauche ich dafür, die TuyaSmart oder SmartLive Bridge?

If you could please keep the conversation in English as much as possible, then more people will be able to participate and help you. If you would rather not or can’t communicate in English then please check out Non-English boards/categories:

Deutsch (German)

Sorry, da hier alle auf Deutsch Antworten, dachte ich wäre im deutschen Bereich.

@Frank62 I think you’ve enabled ‘auto-translate’ with your browser, while all posts in this thread really are in English :grimacing::wink:

And the answer to your question is No, you don’t need any external bridge for Tuya wifi devices.
A Tuya bridge can be used with Tuya zigbee devices.

Beste allemaal,

Ik heb echt wat hulp nodig.

Een half jaar geleden werkt mijn Homey Pro 2019 prima. Ik ben aan het stoeien gegaan om mijn Tuya producten met Homey te kunnen bedienen. Ik heb inmiddels van alles geprobeerd. Tuya apparaten verwijderd in de Homey app.

Met hulp van het “zodoejedatzelf”-artikel was het uiteindelijk gelukt om een Tuya Cloud account te maken en een Tuya Cloud project.

Er ontstond echter een probleem toe ik opeens de melding kreeg: “you are still using the old deprecated api and driver…”.

In mijn “Internet Of Things platform van Tuya” zie ik al mijn Tuya apparaten keurig staan. Toch kan ik in de Homey App nog steeds mijn Tuya-apparaten niet toevoegen. Nu krijg ik weer een melding “Please configure The app first”. Wederom van alles opgezocht en geprobeerd. In de Homey-app bij de Tuya instellingen het dropdown menu “Both”, “Use legacy only” en “Use official only” geprobeerd.

Het probleem wat er dus nu is, dat ik geen Tuya apparaten kan toevoegen, want er verschijnt dan een venster “Nieuwe apparaten gevonden”, “selecteer de apparaten die je wilt toevoegen” en daaronder staat “Please configure The app first” en “Sluiten”.

Kortom, ik kom niet verder. Maar door al dat proberen heb ik inmiddels al 3 van die cloud projecten.

Ik hoop dat iemand mij kan helpen om het nu eindelijk eens werkend te krijgen. Alvast bedankt.

Ik heb al veel gelezen en gezocht, maar mijn Engels is niet zo best,

Ik vergeet trouwens te melden dat het een half jaar geleden, dus via Tuya Cloud een paar weken prima heeft gewerkt, totdat die melding “you are still using the old deprecated api and driver…” kwam.

And still:

If you could please keep the conversation in English, then more people will be able to participate and help you. If you would rather not or can’t communicate in English then please check out Non-English boards/categories:

Nederlands (Dutch)

You probably need to extend your Tuya Cloud API trial.

Check following link under “Q2: Will I be billed after the free trial of the API service expires?”

Hey guys,

Moved to a new house and installed a curtain that has the tuya protocol.
It has been working without any problems before.

Now I’ve created a totally new account on the iOt platform for tuya.
Made the API keys, binded my phone number, linked the tuya app. Everything that has to be done.
When entering all the information in the homey tuya cloud app I get the error 2406, skill ID invalid.

I created a new account since there was no possibility to delete the cloud project on the old one.
But, there is still the same problem.

Can someone point me in the right direction so i can get the units in to homey again!



Hi Martin,

Please read the 1st post of the Tuya Cloud app topic, and look for / search for ‘2406’.

Hope someone can help me with this,
Since last week half of my automations with Tuya cloud devices don’t work anymore.

The app(test version) works and is connected and I mostly use scènes which I create in the Tuya app (tap to run) and use them in my flows because not all devices are supported and less options directly added.

For example, my curtain will open in the morning right after “wake up” and will 50% open 30 minutes before sunset which works both, but at sunset they should close but doesn’t work anymore.

My roller shutters will close at 19:00 which works but won’t open at 07:30 exactly same flow only open close changed.
I have a smart switch for my roller shutter where I used the exact same “open scene” and that works fine.

My spots in the back garden works fine, on in the evening, off in the morning…
My spots in the front garden turn on in evening but won’t turn off.

Restarted Homey again and again, linked Tuya app again with homey, logged in iot platform everything okay there and all my devices in there, subscription okay, made new tap to runs in Tuya app and replaced the scenes in Homey flows, restarted app, reloaded scenes, tried legacy and official, only official.

In the Tuya app on my phone everything works perfect, the Tuya app on homey is installed correctly else I wouldn’t see all scenes (tap to run)

I know Tuya cloud is a bit of luck and there are better protocols but my curtains are important for me and I have a lot of garden spots.

Anyone have an idea?

Only my ledstrip is showing up in Homey and is connected.
But can not add Smart Button and fingerbot/switchbot?