Homey Community Forum

Homeyscript says: Error: ENOSPC: no space left on the device

Hi,

My timers in Countdown (app made by @ralfvd) are disappearing quite often. and when they do so, im using the homeyscript from @Dijker Restore lost Better Logic and CountDown configuration [HowTo] to bring them back.

But the homeyscript gives an error:
image

there is space on the device:

i also removed 2 apps, but same error.
im on 1.5.13 and the app versions are:
Homeyscript: v1.1.0
CountDown: v2.0.3

Anyone who has encountered this?

Greetings,
Marijn

If timers are disappearing out of nowhere, and you’re running into strange disk space errors, you might consider contacting Athom to see if there’s a possibility that they can check if your hardware is malfunctioning.

Oke, thnx will contact them and let you know

I would look at the storage available and try to remove more insights assuming that takes up most space.
Additional to opening the supportcase

There are more people encountering lost timers on 1.5.13 . I understood from Athom that losing settings ( a timer is basically a lost setting ) is a known issue on 1.5.13 ; it could be related to the diskspace issue: when updating timers, it rewrites settings to disk. This might fail when the diskspace is full. As far as I know, There is no feedback from Homey if writing a setting failed, so this can’t be checked.

Athom also suggested that this (‘losing settings’) is solved in 2.0.

As @Dijker suggestes: remove insights to clear up diskspace.

no problems today, script saves again.
Homey did his daily reboot past night, so maybe that fixed it.