Homeydash on Google Nest hub


I made a virtual device called Dashboard and this Dashboard I start every 30 Minutes on the google Nest hub with Google Chromecast. This works great. But the “saved settings” on the nest hub like "zoom setting, clock, which netatmo measure for example (look at the attached device), i have to make new every day. Do you have an idea, what to do, that this will save correctly on the google nest hub?

Unfortunately, you can’t save the settings on a (Nest) Hub. It does not provide that functionality. I understood this is because it has no full browser capabilities.
So you will have to wait until Google implements that (if they ever will).

In the mean time can try to run your own dashboard locally as explained here: Homey.ink, an e-ink Homey dashboard
Homey.ink on a tablet/desktop

When running ur own dashboard, does the hub save the settings?
And the topic u mentioned is about the kobo reader?

Hello, thank you for help. I want to try following link:
GitHub - PeterKawa/PeterDeeDash: Dashboard based on homeydash.com & dash.homeycornelisse.nl. Do you mean this locally link with the Micro Web Server App?

@PetervdK : Did you write the PeterDeeDash instruction?

Hi Ronny, indeed I found and adjusted instructions (& mentioned the sources) and made the dash adjustments to be able to display all available tile values, and I adjusted the layout a bit for Android tablets. But the Google hub layout is also present.
While not having that device, I don’t know if the fonts are of usable size.
Afaik, using it on a Google Hub will make no difference compared to an online dash in case of adjustments made using the dash menu. It seems the ‘cast’ method can’t use cookies to store your adjustments, something like that.
While my adjustments to the tile values are default, they should be displayed while casting the dash.
As I said, I don’t own a Ghub, so it’s not proven / acknowledged yet.
Feel free ask any Q about it

No need, those are hard-coded by my desire.

Sorry, wrong dash topic again… :blush:

1 Like

Never heard of it, so i don’t think i did… :grin:
I assume @Peter_Kawa did…

@Peter_Kawa Currently the “BuienRadar” picture is always pointing to the location “Schagen”, while the weather report is from the Homey-Location, is it possible to have both from the Homey-Location or make the “Buienadar” location adjustable? Thanks in advance.

Hi Jan,

Following the url below, you can, starting from point #1.3), enter your location & zoomlevel:

Then you can copy-paste the generated code into /app/index.html, replace the code between the iframe tags:

<!-- 3 hour rainforecast Buienradar.nl - Centered at Schagen-Netherlands -->
                <iframe src="https://gadgets.buienradar.nl/gadget/zoommap/?lat=52.7875&lng=4.79861&overname=2&zoom=8&naam=schagen&size=2&voor=1" scrolling=no width=256 height=256 frameborder=no></iframe>
                <br />

It is indeed a good idea to use Homey’s location data for this, but I don’t know how yet.

Thanks Peter, that’s really a great option.

1 Like

Does anyone have a modified version for the Google Nest Hub of the PeterDeeDash for me? Got the dashboard working, just don’t get it all on one screen. The rainfall radar keeps going down and so we have to scroll.

Hi @Steven_Bareman,
I adjusted stuff to fit the hub screen, just download it here and use google_nest_hub theme.
Something like


The weather screen is centered at Utrecht, but it is adjustable.

1 Like

Hi, It, Looks great, going to try it next week and will show the result :wink:

1 Like

See the first result here :slightly_smiling_face: The Dashboard works and I have adjusted the weather information to local data and not from Buienradar (not a fan of it and thought it was graphically less beautiful and now i can see the time of the radar)

The next step is to adjust the information in the control buttons and especially the logos. I see that you have already succeeded, so I am very curious how you did that :innocent:

So far I am very happy that I made it this far.

1 Like

Looks cool, I like your weather graphics better too, I think I’m gonna fiddle with it some more.

About the custom icons. They reside in the folder /app/img/customicons
Edit the file /app/js/homeydashapp.js
Look for “CUSTOM ICON per device”, somewhere at line# 1970
There you’ll find code like below and go add your own custom icons:

// My green light
        if ( device.name == "Green Light" ) {
          $icon.style.webkitMaskImage = 'url(img/customicons/green_light-icon.svg)';
          $icon.style.backgroundImage = 'url(img/customicons/green_light-icon.svg)';
          $icon.style.backgroundSize = 'contain'
// Example of the one icon for multiple device tiles 
// My green, blue and yellow lights, edit the first "if" line like this
        if ( device.name == "Green Light" || device.name == "Blue Light" || device.name == "Yellow Light" ) 
// End of examples
1 Like

Hi Peter,

Sorry for the late response, I’ve been busy but I managed to change the icons too :slight_smile:

I have applied the weather information from:

(There is also an animated version :wink: )

I just can’t manage to adjust the background of the dashboard yet, I followed the instructions exactly, but the blue (navy) color remains. Any idea how this happened?


I am having some issues.
I setup homeydash (web) and it all worked nicly for a week or so.
but now when it cast the url to the nest hub v2 i just get the default background, no information at all except clock. the url works fine on webbrowser etc. is there anyway to reset the nest url/cast to get it back up and running?

I just tested, but with a working URL in a browser, it works fine when casting that same URL to the hub?

Did you log out from the Homey app in the mean time? It could be your token code has changed, so try to copy that again.