Homey Zigbee - limit of 20 battery powered devices

hi guys, how can I overcome the limit of 20 devices when I add zigbee devices?
Right now I also have non-battery powered peripherals. but the mesh network does not use them. they all communicate directly with the controller.
Thank you.

I am not aware of a limit. I have the early 2016 homey. The mesh network indeed does not show what the real mesh network is. I expact this is a bug and hope the zigbee rewrite athom is busy with will solve that problem. I experimented with the zigbee powerplugs as routers. Without these i have connection problems with the battery powered devices. The zigbee mesh shows all the devices are 1:1 connected with homey. After plugging in the power plugs the connection problems have solved, but the zigbee mesh shows that all the devices still are 1:1 conbected with homey.

It will often take a while (minutes) before the proper routes are being shown (although, AFAIK, router devices are always shown to be directly connected to Homey, even though at least in theory, they don’t have to be).

1 Like

my network is so formed:

there are about 22 battery-powered peripherals and 3 peripherals that act as routers. all the devices connect directly to homey (even moving it). I assume it’s a homey bug as with other zigbee controllers (see zipgate) for eedomus there are no such problems.
However, trying to add a new zigbee device I always have the timeout

Changed the Title as it has nothing to do with a Pro as Zigbee is the same across all Homey Models.

Please wait 15 minutes and you will see that there will be a mesh network. At first load you cannot see any mesh, but after sometime you’ll see.

But with or without as mesh, there is still a limitation of how many zigbee devices homey can handle… Atleast, that’s my experience.

I did a full reset of my complete zigbee network, and added all my devices again. But after 17/18 zigbee devices (combination of powered and non powered) some devices are loosing connection. Completely random.

I have read that this bug was already present in previous versions 1.5.x now that we are at 2.x.x do you know if they want to correct it? it doesn’t make much sense to have a controller that does not manage more than 20 devices considering that the zigbee network should have much higher limits …

Did you read through the reactions above?

https://community.homey.app/search?q=zigbee%20rewrite

limited :frowning:

you can buy zwave devices or add the rest of devices or even all to Philips hue.

same f. problem.
added as a workaround double sensors

disappointing result

You mean from Philips Hue? Don’t know, i don’t own one.
But it’s probably a generic Zigbee issue, because many controllers have the same problem/limitation.

It’s not a generic Zigbee issue, it’s an issue with many controllers because they all use the same (RAM-limited) SoC.

Sure. I call that generic because it is not specific. But it’s great that you couldn’t resist to reproof someone else. Again. Must be a burden to live with such an obsession i think.

Allright, can you just stop with this kind of bull shit answers on this forum please? Get a live and try to be nice. @robertklep is a very awesome member of this community. Is trying to help all of us. Can’t say that about you.

3 Likes

Maybe do some background check next time before you judge. I help a lot but some ppl that only show off on their own expertise and have to blame Athom on every occasion got an urge to (unfunded) comment lots of my (and some other’s ppls) posts. Just like now. Pulls the fun out of being an active and helpful member, i can assure you that.
And yes, instead of beating around the bush and do it sneaky i just say what i find and feel.

Line> -----------------------------------------

For those who doesn’t understand: i draw a line here. Let’s stop nagging and start being useful.
Next off-topic posts will be deleted without further notice. Reactions to this post will also be deleted.That includes posts where we have to make a statement first to go on-topic again after that. If you have any problems with that please feel free to PM me or any other moderator.

1 Like

It’s strange that your mesh does not use your routers. I believe the limitation is not 20 battery powered devices in total, but 20 battery powered devices per router/coördinator.

My developer page does show zigbee using the routers (ocassionally). Have you tried rebuilding the zigbee network already?

From what I know (also from other sources), the SoC has a 20-device limit, no matter if those are battery-powered or not (there might be a slight variation between controllers, but it’s 20-ish).

1 Like

I’m sorry, battery powered or not is indeed not relevant.

What I was trying to say, is that the limitations encountered by the TS are most likely caused due to the fact that all his devices are directly connected to Homey. Therefore, the network (and the limitation) is not expanded. Or, as the source you provided states this:

“Definitely not! Example given: the default Zigbee2mqtt CC2531 firmware indeed supports 20 devices connected directly to the coordinator. However, by having routers in your network the network size can be extended.”

1 Like

I am also faced with the same limitation of 20 zigbee devices:

  • I have a XIAOMI v2 gateway but it does not act as a router.
  • I also have a HUE gateway but I understood from lisatn other posts on the forum that he builds an independent zigbee network.
  • I have a ZIGATE (zigbee USB key) but I can not add it to HOMEY.

Last solution: https://www.ikea.com/en/fr/p/tradfri-signal-amplifier-10400408/

I hope this product will help to overcome this limitation (material since dependent SOC?)
Do you see another solution?

i use Philips hue bridge for all Philips motion sensors, dresden elektronik strips.
for the rest of motion sensors, innr lamps and hue lamps, I use homey.
each room has now. min. 3 sensors.

first time, that this works how it should :slight_smile:

maybe there is a better working solution? but it works for me :slight_smile:

I’m working with count downs start and adjust
flow:

maybe this will solve your issues also