Homey v2.2.0-rc.4 cannot access app settings anymore

I updated to Homey v2.2.0-rc.4 and cannot access any app settings anymore.
It´s just loading and nothing happens.
Anyone know?

Jup, same problem here. Wil try a ptp. Have you tried that allready?

Nope. Dont know what that is…

Pull the plug. So, power off, wait 15 minutes, and put it back in. Than wait for Homey is up and running again.

My honey is powered off now, so I’m Waiting and start up after 10 minutes. And that let’s see what happened.

Maybe we have to wait for the Android/iPhone app 2.4.0 first.

Tried to pull out plug, but only for 20sec. Nothing.
But what does the app have to do with it?
Ive tried in https://developer.athom.com/tools/app-settings and its just the same.

Any errors in the browser’s console?

In the release notes, they said that some functions regarding the IP camera function become availibe after installing app version 2.4.0 wich is not released yet. They changed something in the app SDK. So maybe that has something todo with it. Don’t know.

Edit: with a “ptp” always wait 10 minutes.

Pull the plug did not work for me. I’m using an android device. My girlfriend is using an iPhone and on her homey, she can access the settings! So it seems to be an app related bug in the android version I think?

Edit: she cannot acces my homey as well…

No errors. Just a faded template of an app setting page and a loading icon. Never seem to end… just loading

Did not work for me either. Had it unplugged for half an hour… bummer…

Did you try to reboot you’re phone, and/or re-install the app ??

No Problem here, updated homey and app, using android and Ipad

Ok. So now, not doing anything it suddenly work…

I’ve rebooted Homey, my phone, re-installed the app, still nothing here… The app is running fine, but just cannot get access to the settings page of apps.

I dont have acces anymore to the app settings either.

I have the new app updated today and also updated homey.

I see rc5 is released. Would that solve your problem?

No, unfortently it is not solved.

The issue is only when you are connected to homey via the cloud instead of a local connection.

If it still doesn’t work when going from cloud to local (connected to the network where homey is also connected to), force close the app and reopen, that should fix it, as it might still get routed via cloud before the force close.

1 Like

You are completly right.
Just tried that scenario and can confirme that is the issue

Athom confirmed on slack:

WeeJeWel [7:51 PM]
FYI there’s a bug in v2.2.0 that prevents app settings & add device from working when connected outside your own Wi-Fi network. We’re working to resolve the issue this weekend.