Homey Pro (2023) unable to get Wi-Fi networks

I just received my Homey Pro 2023 and I have issues connecting to my Wifi. During the setup process Homey is unable to find any wifi networks (there’s a lot in my area). I have tried all of the following (several times) but no matter what the wifi list remains empty:

  • Restarting the setup of the Homey Pro
  • Resetting the unit by inserting the a pin for 30 seconds
  • Updating the firmware and factory resetting via USB
  • Entering my wifi info as if it was a hidden network

Anyone who has experienced similar issues or have ideas how to solve it?

Have you tried the latest Experimental RC118 ?

Not sure you can enable experimental on not enabled-connected Homey right away.
What happens if you enable Wifi hotspot on your mobile ?
Any chance to connect via USB-C network adapter and over Ethernet ?

Thx for the quick reply @Sharkys

I don’t think I can install experimental firmware since I havn’t added the Homey to my app yet.
It doesn’t see wifi hotspot from my smartphone either
I don’t have the ethernet adapter

Tried 2.4Ghz only?

That’s not good. You may want to contact Athom, but their response time is nowadays 1-2 weeks.

Can you try also resetting when booted? (I guess it will not help as USB reset didn’t help already) but you have nothing to loose)

That might be the last chance, to see if anything would change with latest RC118.

There isn’t any USB-C adapter around you, close shop?

Officially compatible :

Those could (maybe) work but NOT TESTED !!!

@PetervdK , good point, I somehow find that natural that all frequencies were tested but you are right actually :wink:

@PetervdK On other devices is see lots of 2.4Ghz networks in my area but Homey can’t see any of them.

@Sharkys I havn’t ever used a USB-C to ethernet adapter so it’s not something I have and I would of course prefer not having to buy one.

Thanks for suggestions though.

Probably because the SSID is equal for both 2.4Ghz and 5Ghz. Homey is known to be picky with Wi-Fi if the SSID is used for both bands at the same time. That’s why i said 2.4 only (ie. switch off 5Ghz). Most modern phones offer the option for either band apart or both at the same time for a hotspot.

Peter, no offence :hugs:, this is true for the white ball Homey’s.

The Pro 2023 should be able to handle wifi6, but imho it can’t hurt to disable that, and split the SSID’s to 2.4 and 5GHz

It’s really odd there’s no wifi network found whatsoever. To test if it’s truly a Homey issue, can you test with an completely other wifi network (like, neighbour / family)?

It doesn’t :blush:

:flushed: I know you’re not kidding this time :wink:, but I can’t believe this is for real

Maybe I misunderstand something but how can I try with a different wifi when Homey can’t see any wifi networks at all? The list of networks is empty.

I already tested if it helped splitting up the bands. Made no difference

What isn’t for real?

Actually, I just realized an important detail I forgot in the original post. The Homey Pro actually did connect to my wifi the first time I ran the setup. But during the firmware update which is right after connecting to wifi, something whent wrong and my phone lost connection my Homey. I then had to reset the setup process and now (the second time I ran the setup) the network list was empty as described.

This detail is probably quite important since it means it’s probably a firmware issue, right?

It’s “hard to believe” phrase, but you are trusted source of very critical view on Homey thanks to many years of working with Homey and Athom, so we trust you still can’t believe it even it’s true :slight_smile:

Oh, you mean that HP2023 does support WiFi6? Because it really doesn’t: it supports 802.11ac on 2.4 and 5Ghz (aka WiFi-5), but not 802.11ax (aka Wi-Fi6).

1 Like

Can you do USB backup, using 7Zip open the file, extract it and find homey-pro.log on /user partition ? It will help to troubleshoot I’m doubtful it will give you some (re)solution though :frowning: Also system.log might be interesting

I didn’t check myself but somehow I was expecting that it would support it. True is that already 5GHz is big advance :slight_smile:
I guess it’s limitation of CM4 module, so after all no surprise after all.

None taken at all… :smiley:

I created the backup but I’m on Mac so it can’t use 7Zip and I haven’t been able to find another app that will recognize the format. Apparently this is not supposed to be easy :person_shrugging:

It would be nice if there was a way to downgrade over USB so I could try an earlier version of the firmware to see if it would work. But of course it would probably loose connection as soon as it upgraded itself again.