Homey 2023 stuck on wifi selection, no lan offered during setup


I received the new Homey 2023 -PRO-EU-03 from ROBBshop.nl today. Also the HOMEY-ETH-01 adapter was included. I am trying to setup the new homey where I do not want it to connect to wifi. During the setup procedure, I get stuck on the network page where I cannot go further without choosing a wifi network.

To make sure all is in order to connect by LAN, following troubleshooting steps where taken:

  1. test lan cable with laptop → gives perfect gigabit connection @900mbps+ speedtest towards internet
  2. Homey ethernet adapter is connected to the homey power adapter, the long homey usb-c cable is connected between the Homey ethernet adapter and homey 2023 (compliant with the manual)
  3. homey ethernet adaptor led’s are blinking, but no ip address is requested from the router
  4. restarted homey by taking out usb-c cable from homey itself and repeated setup again → still no ethernet
  5. restarted homey by taking out ethernet adapter from the power adapter → still no ethernet
  6. setup homey by wifi, including homey firmware upgrade, and checked ethernet → no connectivity
  7. factory reset homey and restarted setup procedure → still stuck on wifi selection, still no ethernet

What am I doing wrong?
I am an IT admin and should be able to figure this out, but I think I have to conclude something is wrong with the ethernet adapter? (I plugged the ethernet adapter in a windows 10 notebook, but it is not working. Not sure if there are drivers for it, but it doesn’t even shows up in the devices list as an unknown device)

Any ideas?
I have sent this to Homey support too)


UPDATE: the usb-c cable that came with Homey is defective. I tested with the usb-c cable from my Samsung smartphone charger

Welcome to Cablegate :face_with_peeking_eye:

1 Like