Homey Pro 2023 loses connection to cloud (server) and is offline

Hello everyone, perhaps several users are experiencing this. I have just consulted Homey Support for this problem and am curious if other Homey Pro 2023 users are experiencing this as well.

For the past 3–4 weeks I have been having issues with my Homey Pro early 2023. It regularly loses connection to cloud-based apps. It goes like this: for some unknown reason, the Homey Pro loses its connection to (I suspect) the cloud (servers). Local devices will then continue to work, but you will no longer be able to operate the Homey via the mobile network and apps in the cloud will no longer work either. Homey indicates that it is connected to the Cloud, but that is not the case. The local IP address indicates that the Homey is active, but has lost its connection to the internet. You can also no longer use the Homey in combination with Google Home.

The only solution is to restart the Homey. Then everything goes well again and after a while it loses the connection again.

I have already tried several solutions:

  • Restore WiFi
  • Disable WiFi and use it on an Ethernet connection
  • Devices giving errors removed
  • Cleaned up flows with cards that were no longer accessible
  • Everything updated to the latest software updates

Unfortunately, the problem remains. Good to know: the Homey is connected to a 5.2v adapter.

In short: Homey loses connection with Cloud. As a result, you can no longer use cloud-based apps, you can no longer access the Homey via mobile network, Google Home no longer works and you will see the message ‘Homey offline’ with some apps. However, Homey is connected to the internet, but communication with the server has been lost. All devices that run locally via z-wave, Zigbee or locally via WiFi work.

Do you recognize this problem? If so, respond and submit a support request: Support | Homey

1 Like

Mine goes offline quite regularly I’ve been in contact with support for a while now, haven’t fixed it yet.

1 Like

I have exact the same problem… since september. I need to hard Restart it every time.

1 Like

Right now 21-12-2023, about 2 p.m. I notice the same thing. About one month ago as well. After a reboot everything worked it again. I can’t access my Homey now so I am Googling for a solution. Actually see a simple (I think) solution. I also have a Hue Bridge and connect a smartplug to it. I can connect to the Hue Bridge and can then turn that smartplug off and on. Obviously not a fancy solution, but will work I think.

I used to have same issue with regular disconnects (both Wi-Fi and Ethernet connected) even after swapping to 5.2v PSU and doing all the other stuff Athom recommend. I’m using an Orbi Mesh Network so didn’t think it was that as very reliable so decided as a test to put a very small little UPS on my Smart Home kit. I added main router, DSL, Homey Pro, Philips Hue , Gardena, Blink Controller and a few other bits etc. and since then it has been very stable, over a month of uptime sometimes without any issues, normally the firmware update is now my point of reset in last few months.

In all honesty having checked power supply and the mains feed I cannot see why this made a difference as both were seemingly stable and it could be coincidence but for me it seems to have stabilised my whole Smart Home Set up and if nothing else all Hubs and Homey will stay active during a power cut for just under two hours so was a useful investment as I have Smart Door locks.

Suggest also using a good quality Ethernet cable for the Homey and making sure the Homey Ethernet adaptor is correctly set up, it is possible to connect this the wrong way round (I’m sure you haven’t but worth checking).

Same here, just submitted a support call. No internet message, both wifi and ethernet. Locally/VPN everything works.

After a reboot everything goes back to normal.

1 Like

Same here, after getting of the power en then turn it on again its works. But ill have to do this every day!

Same for me. It started off irregularly, but now it looses connection every day. I have to pull the plug to get it back online. Please post the solution here if someone finds one🙏🏻

For me as well.
Started with losing connection but automatically reconnecting.
Then, losing connection but I was able to reconnect from within my network management (UniFi).
And now it loses connection daily and is not manageable anymore from the UniFi app. Only a PTP works. This is really not workable and acceptable.

You’re so lucky. Many offline issues happen multiple times a day.

I don’t say it’s ok, even if it fails once a month, Homey should not go offline when there’s no network issues.

I’m experiencing a similar problem with the Bridge. I attempted switching from a 5 GHz to a 2.4 GHz Wi-Fi network, but unfortunately, that didn’t resolve the issue.

I can’t remember the bridge is able to connect to 5GHz, but my memory isn’t 100% reliable :sweat_smile:

This useful info also goes for the bridge (it shares the wifi implementation with the Pro 201x):

1 Like

It’s not.

A new Beta release for HP2023 has become available, that should monitor the wifi connection and should try to reconnect when the connection has been lost.
I just updated my unifi network so first want to see if that also improves. If not, I will try the beta.

Since today, my month-old Homey Pro is offline…
Can’t connect to it from the app or web.
Powercycled it twice now: it shows white led for a while, then breathing red for 10-20 seconds, then spectrum (seemingly ok) - but still offline.

Ok… 5 (!) powercycles later, Homey is finally online again (yes, every one of those powercycles had at least 10 seconds of no-power). Still using the 2.1A power adapter that came with HP, don’t see how that plays a role here.

Annoyingly, but not unexpected, all 5 INNR SP240’s are now in error state. Not unexpected, as the SP240’s, as reported in a separate thread, can’t handle connectivity issues.

Really disappointing - WAF is near zero and even my tolerance for error is challenged by this.

Just restart the Innr app after each reboot. I have created a flow for it.

1 Like

10 seconds??
Make that 5 minutes to make sure all capacitors and stuff really lost their charge.

Really? This is not twitter or such.
We all understand you didn’t ask for those issues, but, please,
can you refrain from that childish feeling sorry for yourself and complaining.
This is just a technical user forum.

Instead please send your emotional stress to Athom https://homey.app/support instead. Thank you.

Excellent suggestion, thanks. Added it just now!

Hi to all. I have the same problem and today when i was out of the home, the allarm ring for 3 hour, and i cant make nothing because the homey pro 2023 was disconnected. In local no problem, but out of the home no connected…