Homey Pro 2023 firmware 10.3.0 - zigbee is broken

Hi, this update is killing my devices. First smpl display stopped working and lookes like bricked, then my multi color lights (lidl added as generic zigbee device) stopped changing colors and display some error with with unknown cluster… Is there a way how can I downgrade without any need of re-adding my 80 zigbee devices?
I am really thinking of going back to HP Pro 2016… After migration to HP 2023 everything went to… (or is going to with every update)…

1 Like

You allready tried a PTP with Homey? (Turn of the power for 11 minutes and then power on)

No I havent tried, wife would kill me if lights isnt working for that long, have to try when she is asleep :joy:

Do you have Thread devices connected to Homey?

(reason for asking: the folks at Home Assistant don’t recommend using their Sky Connect dongle for both Zigbee and Thread together due to stability issues, and that dongle uses the exact same chip that Homey does. So where HA recommend not using both protocols at the same time, Athom apparently said “hold my beer” :man_shrugging:t3:)

1 Like

No, I have around 80 zigbee devices, 5 Z-wave, and 20 cloud devices. No thread (at least I haven’t added anything with thread protocol).

I have 37 Zigbee devices, the first 5 thread devices and it works like a charme. No issues or delays with Zigbee actions.

Now I tried, and same problem :pensive:

Usually PTP is not required for so long but you can still simply try to do a another restart.
Also, try to cut those particular lights from power, might help as well.

If it’s bricked, it’s for sure not due to the Homey.

Btw, why generic ? Have you tried to add them via Tuya or via Lidl app ? (I would recommend Tuya)

Right now it shows that ita ready for pairing, but when i try to repair device in homey its not connecting (same as lots of smpl display user :roll_eyes:)

These panels are not recognized by any app (tuya or lidl)… My experience is that only bulbs from lidl are supported, any other zigbee lights from lidl is recognized as generic zigbee device (and sometimes doesnt have some capabilities - so I had to make custom copy of tuya app and write my own driver for that light)…

And you used TEST Tuya app, correct?

Just to be sure, go to Homey Developer Tools, and try to ping every device which is ROUTER - if every one will respond, check which firmware you are running on the same page and what is the status.

If everything is OKay, maybe you can also try factory reset and reflash, eg. via USB.

Have many different issues with HP23 but speaking about Zigbee, not exactly this ones :wink: It’s actually getting better and better with my >70 devices.

Is it not accepting generic zigbee devices anymore, but requiring a dedicated app?
In a recent firmware (10.2.0) there was a new requirement implemented, I think.

I also have a couple of Lidl bulbs and RGB spots that does not have support in any apps. Will they be useless?


Holding the firmware upgrade for now.

Usualy a PTP is not necessary but sometimes it will help.
PTP, at least 10 minutes.

That article was written back in 2019, while being HomeyPro owner of different models ~6 years, I never had to do PTP for so long, more over I do not think for HP2023 10 min is required to discharge circuits at all. This is based on my experience with 70 Zigbee devices (even on HP19).

Naturally it may differ if you unplug just the power supply from the outlet or you even disconnect power supply from Homey itself after disconnecting.

@Sharkys I did have to do a PTP once with my HP19, and a normal reset did not work.
With my HP23, I have not done a PTP once. Only a reset after a firmware update.
But when someone states that they have tried everything like also unplugging and plugging in and it still doesn’t work. Then a PTP might solve that. Then you can be sure that all components are de-energized. I think there are also capacitors on the PCB and they hold the voltage for some time.

Tried test, and regular… :slight_smile: I have posted request for adding those lights to Homey forum, but its more than year without adding anything I have requested. So, I have added one type as generic zigbee device (and everything worked as charm until 10.3.0) and build custom version of tuya zigbee app with driver for 1 specific light.

I have tried PTP for 11 minutes without power, tried to re-flash 10.3.0 firmware via cable, tried to repair device… nothing worked. All routers in zigbee are working OK (those lights are also routers and work ok).

I have zigbee firmware

Only thing I would not like to do is factory reset and re-add all 80 zigbee devices… Last time (when migrating to HP 2023 from 2019) it tooked me a whole day :frowning:

When you do factory reset with restore, you do not need to re-add all devices.

If you tested ALL routers, successfully pinged them, then it’s really odd.
Can you share view from the dev / zigbee ?

For Tuya, you do need to use Github, not forum - what is the product ID ? Recently Johann added about 400 devices.