Home Assistant Device appears as wrong type?

Hi All,
I’ve just been playing with Home Assistant and added a switch on HA and tried to import via the Homey HA app

When it’s in there however it appears as the wrong device - it’s an Aqara switch but oddly shows temperature

Anyone know why this might be?


Assuming you installed the Athom HA app, I’d like to recommend the community HA app

Ah okay, I was aware of that but I think because I saw the other in the standard store i assumed they were the same!
Will give that a go!

How long does it typically take for a community store app to install?
I’m authorised and the community store app is installed on my Homey but not seeing the HA app being installed

No there not the same, the standard store app is pretty basic.

Installation shouldn’t take more than a minute. The app replaces the Athom app, you should see “Rob Groenendijk” mentioned under “Home Assistant” at the app listing.
Are you logged on?

Screenshot from 2022-07-23 18-06-18

Yeah I’m signed in and I get the prompt saying it’s installing but nothing appears in my Homey

Unsure if this is something odd on mobile, but will try on desktop when I get a chance

Indeed try an other browser. With Firefox it seems to work best. And / or start browser in incognito mode. Logon again and give it another go.

Really odd… I’ve just tried all browsers, it at least makes the right moves
The HCS site can read the apps installed on my Homey, the HCS store is installed with v2.2.1, but nothing I do actually seems to make the apps install on Homey… not sure what the next step would be :confused:

Do or did you have other Homey’s?
Does Homey’s name match?
Do you have a pi-hole or other ad-blockers?
Maybe log off of Homey and all related sites, and logon again makes a difference

Maybe start reading the store topic from here…

Hi @Peter_Kawa

Thanks for your reply. A few weeks ago one of the creators fixed something. Can’t remember exactly what, but it had something to do with Homey blocking something on their end.

Anyways, problem solved!

Oh strange, what you’re describing there Dennis is exactly what is happening to me :frowning:

Hi Dennis, I was replying Vaderag and quoted your issue while it’s similar :wink:

Sorry man. Didn’t notice. :+1::+1::+1:

1 Like

Has the community store been killed?

Tried two devices and I just get the below when trying to authorise after clicking allow so I no longer get the code?

Or is it just bad timing and something had broken?

Try while using Firefox browser

That worked for sign in, thanks.
I uninstalled the HCS app, and successfully re-installed it via the installer…
Unfortunately I still seem to be unable to install any apps via the HCS… (still using firefox :wink: )

Any other thoughts / ways?

Also, as an aside (and actually more important to me right now), is there a way to reveal Homey devices to Home Assistant?

EDIT: I tried installing a different app (SmartThings, don’t need it just wanted to see if issue was related to Home Assistant) - it seems that it has caused a colossal failure in my Homey now - I seem to be in a reboot loop (presumably as it tries to install, fails, and breaks…)
Not really sure how to fix that now

Power Homey off,
(optional: wait for 11 minutes),
power it on,
turn it up-side-down,
Wait for aprox. 1 minute,
Open mobile app,
Goto …More
Select your Homey name (at the top),
Select ‘Add new Homey’,
Connect it with your wifi,
You can try the ‘Full software download’,
Or restore a backup of an earlier date


Sure you are logged in?
For mobile Firefox: enable ‘Desktop mode’
Hit the green thing on the upper right


(Note: The MQTT broker can be installed as add-on in HomeAssistant, instead of on the NAS):

I managed to get into a stable state by disabling the HCS in the brief period that I had before it crashed while loading the apps list… If I see any other issues I may well do the above

I have Zigbee2MQTT set up on HA so already have the MQTT broker running so will check that doc out! Thanks :slight_smile:

Also using this opportunity to create an official Homey Backup with my free trial… may as well get one in there!

1 Like

Nice to hear.
You can buy Homey backup for the little amount of $ or E10,- a year here. It saved my ass twice already!

1 Like

Looks like I didn’t solve the issue. Homey crashed overnight and back in reboot loop.
Just tried the above and the backup has the same issue… :sob:

Any way to clean up any remnants from the HCS using cli or similar?