Homey Community App Store

The problems you are having are unusual as it normally installs the store app without issues. However, Athom do constantly changed things, which can sometimes cause problems. Plus, there can be various user configurations that also put a spanner in the works. @MaxvandeLaar has done a great job providing the Community Store and he is not responsible for the Getting Started - Homey Apps SDK ,that is produced by Athom and aimed at developers, which is not normally required to install the app.
I can understand the frustration when things don’t work and we also feel it when we see users experiencing problems but all we can do is our best to help.

So can I assume that you manged to get the CLI up and running to be able to log out of Homey?

The installer that is installed by the exe is version 1.0.0 and that will automatically updated itself to the latest version once it is running on Homey.

As @Adrian_Rockall mentions already, I do not work at Athom nor have any involvement in how they do things (sadly :wink: )

The Get Started actually has a step by step guide as well if you scroll past the video. You only have to do step 1.

Ensure you have NodeJS installed Node.js

After installing NodeJS, install the Homey CLI by running npm install --global --no-optional homey in your command line interface. After that you have installed the Homey CLI. If you have that installed, let me know, so I will guide you in a DM how to install the HCS app in an alternative way without using the installer.

The installer is build to help users to install the HCS app on their Homey as Athom doesn’t allow that app in the official store. Feel free to contact Athom about this if you feel they should :wink:

If you need help with anything else related to the HCS let me know. I am always willing to help, but please note I am doing this in my very limited personal time and cannot control any changes Athom makes to the Homey.


I eventually worked out what I needed to do (as someone new to this the instructions in the link were not straightforward). The app still didn’t install, so @MaxvandeLaar can you please guide me through the alternative way of doing this?

I will contact Athom about adding the app to the official site, and maybe point out how the current advertising is breaking Australian consumer protection laws (relying on customers reading the fine print doesn’t cut it).

1 Like

Again trouble with acces and install a app.
I deleted the community app from homey a while ago.

But now I want to use it to install the Nuki Direct app
cotact with cli.athom.com doesn’t work an the site won’t give me a code to access.

V2.2.2 is installed on my homey
The Nuki app stays gray and I can’t install it

Dont know what I do wrong …

The logon in HCS redirect you to a https://aip.athom.com/oath2

Remove all your Cookies or try it from another Browser or an incognito window, that logon works here,

Hi all,

I have a problem. I can login the Homey Community Store without problems. I can install the HCS app without problems from a Windows 10 system. The minute the HCS installer is done the app pops up in my Android Homey app. But after this I’m unable to install any app from the HCS. I used a Chrome browser and the Edge browser from my Windows 10 system. I used the chrome app on both my tablet and my phone. And I used Mozilla from my tablet and my phone. I can login to the community store without problems on all devices. If I click on “install” for any app, I get the message that the app will be installed shortly and that I’m not able to track the installation status.

The strange thing is is that I installed the community store before and I was able to install apps back then. I even have those apps still installed on Homey. But because I was unable to install HCS apps now, I deleted the HCS app, restarted Homey and reinstalled the HCS app without problems.

If I uninstall the HCS app from Homey and then click the install button of any app, I get the message that the HCS app is not installed, logically of course.

Any suggestions?



Hi Peter,

That I did do. If I didn’t, the “install” button for the apps would be greyed out, right?

On my mobile devices I used the “desktop site” function.

I remember last year I had the same problem. I wanted to reinstall my Homey anyway back than, so I did. After a fresh install I was able to install apps from the HCS. But that stopped working for no apparent reason.

Any other ideas?

I did not read your post very well :sweat_smile: my apologies.
Do you have multiple Homey’s? Make sure the right one is selected

And try Firefox in Incognito mode.

Logoff from your Homey ('s) and all related sites.
Then log back in and try to install the community app.

Have you tried rebooting Homey after installing the HCS app?

Hi Adrian,

Yes, did that. Didn’t help. I do remember I had the same problem last year. I wanted to reinstall Homey, so I did. After a clean install it worked, but it doesn’t now.

I also logged out and logged back in through CLI.

Is there a way to uninstall CLI tools and reinstall CLI?
My knowledge doesn’t go that far.

Also, @Peter_Kawa thank you for your answer.

I already tried multiple solutions mentioned here before posting. But I’m hitting a brick wall with this one.


Do you have a PiHole or something like that as local DNS?

I downloaded the HCS app and it’s running on my Homey Pro, I can see it from my profile on the HCS website. But it won’t install any apps, tried two different browsers over the last two days. Tried to install two different apps but none of them will install.

Any ideas? I would really appreciate the support.


Here having the same issue, the HCS app is installed on my Homey Pro and I cannot install apps from the store. Tried Chrome and Firefox both in normal and private mode and restarted Homey Pro and the HCS app multiple times. Nothing is happening.

Some help would be great!

1 Like

Confirmed. It worked fine for as long I use Homey (1.5 yrs), but I can’t install tadoZones v1.2.2
I managed to install v1.2.0 a few days ago.
I tried to install Broadlinkred, but nothing changes @ Homey…

No fancy network stuff here, just a default kpn wifi modem
Nothing’s changed recently…

Same here. It was working yesterday, but today no dice.

Just tried using this store for the first time to download Broadlinkred app and was not able to install any apps. When I click install I get these messages:

The app will soon be installed on your Homey
The app will be installed by the Homey Community Store app on your Homey. Sadly, at this time, it is not possible to determine when this completed.

And then nothing happens. Only now I’ve noticed this thread and that I’m not the only one with this issue. I used chrome to download the installer and got the Community Store app on my Homey Pro. Then I tried to log into the community store from another browser, I used Edge, to see if that solves it, but I’m greeted by a white screen with a Homey logo.

No, nothing like that. I do have a TP-Link Deco X60 mesh system, but I turned the mesh function off for Homey.
But unfortunately not a single app will install.

The HCS does install without any problems, but apps from the store itself won’t.

@Rocodamelshekima @MaxvandeLaar any ideas? After my post a few more people report, to what it seems to be the same problem.

Sorry for the inconvenience, it should work again!

For some odd reason the web hook used to install apps on Homey’s got (automatically) disabled by Athom.


I’m still unable to install any apps.

That screenshot means it is going to install the app but cannot determine from the HCS website if it succeeded. It can take a few minutes before the app actually gets installed. How long did you wait, and what app are you trying to install?

1 Like