Google nest flows don’t trigger with new doorbell

Firstly, I love Homey. I use it for everything in my house with great success. I had been waiting for Google nest integration for ages and when it arrived as a dedicated App from Athom I was over the moon! Finally a way to hook up my thermostats to my flows!

I added the thermostats a few weeks ago and they seem to be working fine. Last week I bought a new Nest video doorbell (wired) and set it up. I’ve added it into Homey and started to create flows with it. However my doorbell doesn’t trigger any of my flows. I have a couple of very simple examples that adds a message to my timeline if the doorbell button is pressed or it detects motion however they are never triggered. Is anyone able to help?

I have allowed Google to share my doorbell data with Homey (basically ticked every box!)

What’s confusing is that my thermostats seem to work fine, it’s just the doorbell that I added recently that doesn’t seem to work.

I am using version 0.8.0 of the Google nest app.

Thanks to anyone who can help.

I tried reinstalling the Google Nest app again but the doorbell still doesn’t trigger any flows.

I contacted Athom who asked for some more information which I’ll add here to be as helpful for the next person as possible:

Q: Is the doorbell visible in the Google Home app and functioning correctly?
A: The doorbell appears in the Google Home app and in the Nest app. It seems to be working perfectly with Nest, including starting a video call to my mobile phone when someone presses the doorbell. I also receive motion and person alerts from the Nest App. In Google Home I am able to review videos of previous events.

Q: You mentioned that you ticked every box to allow Google to share information with Homey. Could you untick and retick those boxes?
A: Yes. I did this by going into the following menu in the Google Home App on my mobile phone (iOS):

  • Home App Settings > Partner connections > Homey
  • I unticked every permission (including all of the individual devices)
  • I then clicked the back arrow and closed the settings window so that I’m back in the main Google Home app menu
  • I waited for 3 mins to allow things to happen in the background. Going to Homey I can still see the Google devices however I guess that they wouldn’t work now
  • I then went back into the Google Home app and re-ticked all of the permissions again
  • I then clicked the back arrow again and closed the settings
  • I waited for another 3 minutes and then launched Homey
    I pressed my doorbell and nothing happened in Homey. I did receive a video call from the doorbell on my mobile phone through the Nest App.

The next suggestions to share a flow with the doorbell in. I won’t share that here.

Consider using the community google nest app.

Thank you for the suggestion Peter. I will go down that road if it can’t be resolved but I’d like to get to the bottom of this first. There is no reason it shouldn’t work after all

Agreed, but I’m focussed on ‘how can we make it work’ :wink:

That works for me, it works perfect