Google Nest SDM

Ah, yes I restart Chromecast every morning, TTS app is quite stable here.

1 Like

I have this same problem. At first the “Login with Google Nest account” button did nothing so I deleted and created a new “Device access console” project. This got me a bit further as now the login button brings up a new page on “” but I have the same “Something went wrong” message.

The log shows these 2 messages (in order):

  • login() → no existing OAuth2 client available
  • login() → created new temporary OAuth2 client

Something went wrong is an error that comes from Googles Partner Connection Manager:

Something went wrong

Message Description
### Please contact the developer of this app if the issue persists. This error occurs when the Project ID specified in the PCM URL is not found or invalid. Make sure to use the correct Project ID for your project.

check your project id (use the project ID not the project name!!!).

Thank you for responding so quickly, I’ve checked the project ID (copied it again) and I still have the same error. I also tried deleting the “Device Access” project and creating a new one and using the new project ID but with no success.

I’ve analysed the URL that is being called and the project id that is part of the URL is not what I’ve entered. Perhaps it’s an old one that is being cached by the app for some reason? Manually crafting the URL got me further but there is still something about the URL that I’ve got wrong as now I get a different error:

{"success":false,"message":"Invalid token: undefined"}

Another thing that I did notice during the setup is that when I pasted the OAuth client ID (that was on the clipboard) into the setup window it was invalid. It included “http://” at the beginning and an additional “/” at the end that I had to get rid of for it to be accepted. This may not be very interesting but it noteworthy I think.

I wonder at this point whether it’s worth uninstalling and starting again? I’ll fiddle with the URL for a bit longer…

That is weird, no reports on this behaviour.
Could you restart the app and pm me the log a minute after the restart

TLDR - all fixed

I didn’t have any logs from the App as I was trying to figure out the URL just using my browser. But the upside is that my issue is now solved. This is what I had to do to resolve the “Something went wrong” error and also a subsequent problem where the doorbell was detected but didn’t seem to work (more below).

I decided to reinstall the Google Nest SDM App. To do this, I went into the App settings and clicked “Uninstall”. I was then unable to reinstall the App by clicking the “Install” button on the Community Store. It just wouldn’t install the App however long I waited. Searching another thread (this one) someone suggested reinstalling the “Homey Community Store” App completely which I did. After doing this I was then able to install the Google Nest SDM app.

I had kept a copy of the OAuth client ID, secret & project ID which I set up previously following the instructions. I copied them into the same fields as before and hey presto it all worked first time! I was able to get to the “Google Nest permissions” page finally! I suspect that there were 2 issues the first time:

  • Pasting the client ID also included “https://” at the beginning and “/” at the end. I think that my iPhone thought that I’d copied a URL and was trying to be helpful. It was not helpful.
  • I had trouble setting up the new Device Access project (possibly due to the pasting issue above) so I attempted to create a new project a few times and consequently I had to set the project ID more than once in the app settings. Looking at the URL that the app was calling (and researching what Google expects) I could see that the project ID was wrong. So I think that updating the project ID in the “Google Nest” tab doesn’t seem to make any difference. The JSON above that contained “Invalid token” was as a result of using my browser so it probably wasn’t a well crafted URL. Apologies for the distraction.

The next problem that I had to figure out was why I was able to add my Google Nest Hello Doorbell (Wired) as a device but I was unable to use it at all. The status was not updating and it would not trigger any flows (sounds familiar). After a lot of trial and error I discovered that 1 of the Nest permissions I’d enabled was preventing the doorbell from working. I’ve written this up in the original topic I created here.

Thanks for the great App and for responding to my requests for help so fast.

Thanks for the feedback, start having fun

1 Like

I installed the Google Nest SDM v.7.0.0 from HCS, followed the tutorial but whatever I did I was not able to get the “Login” button under Authorize . Legacy Nest worked so I could add the Nest Protect.
After a couple of days trying ve up and tried downgrade to v6.4.2. Now there was no problems adding credentials and device id and I managed to get everything up and running,. Upgraded then to v7.0.0 and everything looks like working, so of to some flow testing

Thanks for the feedback Eibo. Will check into it, and fix it.

On another topic, do you have some feedback on the tutorial, as it is completly new…

1 Like

I must say that the configuration interface in v.6.4.2 was easier to manuver in with direct link to the different Google Cloud “parts”. In v.7.0.0 it was a little confusing going into the setup documentation and then back into GNDSM configure (a lot of back and forth). I really liked how you solved it in 6.4.2
I’m not to familiar with Google Clouds so it took some time to trying to do things on the computer instead.
The documentation was nice to follow with direct link to the different console parts, but of course because of the necessary to go back into the App all the time made me to skip enabling of the resource API at first. On the other hand, I followed the documentation and found out that after a while, which did not solve anything for me in the v.7.0.0. So doing the configuration in v.6.4.2 with all the info ready in my notes, that was just 30 seconds process and done :wink:

1 Like

The ids and secret text fields seem to be labels. I can’t change them. Is that by design or a bug?

Met vriendelijke groet,
Erwin de Baat

It should put the fields read only when authentication has been successful.

Martin Verbeek

I’ve changed the secret after the update, because I got a 403. Now I can’t update field. Is reinstalling the only way to go then?

There is a way around.

Install 6.4.2
Logout in the app.
Go out of the app and back in.
You should be able to change the fields.
Login again

Martin Verbeek

After reinstalling I got the same result als Eibo, which he mentioned 15h earlier: No ‘login’ button under ‘Authorize’.

Hi Erwin, did you install 6.4.2 without removing the previous version?

I did a clean install of v7. I solved it by installing 6.4 and then upgrading after the setup. Seems some code is missing in the clean v7

So i can work relaxed on a fix now :slightly_smiling_face:?

Martin Verbeek

Always. I would never push for a fix. I very much appreciate your work, so I can always wait. Thanks!

1 Like

Google has communicated that the out of band authorisation for the Legacy interface has been discontinued. I used this interface to get a code in a simple way to add Nest Protect and added functionality.
I had to change that to a new way of getting authorised. In the version i am about to release on HCS will contain that change. It should leave current, still running, implementation unchanged. But NO guarantee, as i lost access to the previous auth code, when i reinstalled the app.

instructions on how to get the new auth is in the setup guide, you can access that through the app when it is released or look at it now:

The problem with the login button not changing is also solved in the upcoming release.