Fibaro Smart Implant

I didn’t mean it that way. On the contrary, I think it’s good that we asked the same questions. So it can’t be that wrong what we asked.

I think the wiring is correct but will double check.

How did you get to the data view shown in your video?

Homey Developer -> Tools -> Devices

Thanks @DirkG , problem solved. It was my wiring. I had connected to the wrong earth wire, one which was in series with the first reed switch, hence the strange behaviour.

Hi guys,

I just added my fibaro smart implant to homey successfully, but the implant does not report any values nor alarms, after it is added.

Just after it is added, it reads the internal temeperature sensor and its value is shown in Homey app. I have set the report interval of internal temperature sensor in advanced setting to 5s, but it does not update at all - right now it says “Last Updated: 28 minutes ago”. I am playing with this for several hours, I never saw it updated. The report treshold for internal temerature sensor is set to 0,1.

Also, when I close contact on IN1 and IN2, no alarm is triggered. I have these inputs set to Normaly open contact in advanced settings, so when I close them alarm should be triggered. However, the Alarm input 1 and Alarm input 2 never get activated. I know these buttons work, because when I click them three times during the inclusion process, they activate the inclusion process, just as if I clicked the B button of sensor itself.

I use this wiring:

In place of binary sensors I use regular wall switches for testing purposes, but there will be an Paradox alarm pannel connected to them when ready. I also included ampermeter in she scheme (between power supply positive node and implant’s “P (red)” node.

The z-wave connection is working - when I change advanced settings in Homey APP, they get saved, no error is reported and values get updated in When I click “test” in developer web, it reports “Node 13 is reachable”. When I start the range test on sensor itself it finishes with green light indicating that “the device communicates with the main controller directly”

I tried restarting the sensor, reincluding it, restarting homey, and I also tried it with experimental Fibaro app v3.0.6 - nothing seems to work. Even when I changed inputs 1 and 2 to Toggle button / Bistble button in advanced settings, it did not work. My Fibaro smart implant just won’t report anything.

Any help with this would be highly appreciated.

Thank you,


Seems to be other people with the same problem. I’ve read that Athom is looking into it. Something with the app.

Thank you Martin,

I searched thru the forum but I did not find any posts related to mine. Can you give me any link to such a discussion, please?

Thank you

And I’ll be surprised if you’ll find. The implant works fine. The only current problem is that Athom hasn’t implemented the humidity reading.

That’s weird, the internal temperature annoyingly reporting often its values (I turned that off myself)

Just to make sure, you are switching IN1 and/or IN2 to ground (GND) and not positive, don’t you?

My implant also works well. You can see that on the graphic/video at post #19 (input 1 + 2 / output 1 + 2). With the default settings also the internal temperature is transmitted regularly.

In my opinion the following possible sources of error:

  • SI is not in range of Z-Wave network
  • SI is connected incorrectly
  • SI is defective

But what I found out after several tests and does not work is to set the option „Push button / momentary button“ (parameter 20/21) on input 1/2. Changing the parameter 20/21 in „Normally closed contact“ or „Normally open contact“, which is intended for reed contacts, for example, it works.
But according the problem that „Push button / momentary button“ doesn’t work, no Scene Activation is possible.
Also, there is no action card where I can select single, double, triple press or hold and release to trigger Scene Activation like it is mentioned in the manual.
I have already reported the error to Athom, but can any of you confirm this?

Well apparently not for some:

Absolutelly, I have these connections made:

  • Supply GND node → Switch 1/2 → Fibaro IN 1/2 node (yellow and green)
  • Supply GND node → Fibaro GND node (blue, the one that is between P and IN1)
  • Supply positive node → Ampermeter → Fibaro P node (red).
    It’s just like in the wiring diagram I sent, except for the ampermeter (I used it to make sure the circuit is working).

I’ll just repeat that the buttons do work - when during the inclusion process Homey asks something like “press button on smart implatn 3x”, I can also press those switches 3x and they activate the inclusion process, so they do work. Also z-wave communication with fibaro works - inclusion, settings change, test communication in developer web app, range test on smart implant, everything works, but no events are being reported (internet temperature sensor, closed/open contact on IN1/2).

I am clueless.

Any more ideas?

1 Like

Hi Fantross,

During these tests the distance between SI and Homey is 1 meter open air

Should not be the issue, I checked and rechecked the wiring diagram, it is not rocket science I believe I have it right. Also if SI was connected incorrectly, the inclusion would not work, the 3x press of IN1/2 buttons during inclusion would not work and the first reporting of internal temperature sensor would not work.

Same here, I was surprised that I did not find it there and I was wondering how I would use scenes in a flow, when there is no such WHEN card for SI. But I was going to deal with this later, after I repair this problem with SI not even repoting.

Martin Thank you! That’s exactly my case. I did not find that thread because it is not in english. However there is no resolution still :frowning:

Not sure everyone here speak Dutch m8.
Thanks for pointing anyway

1 Like

I’ve got a brand new implant, I shall try include it tomorrow and see if same issues like yours. But yeah, I am out of ideas for now.

1 Like

If the power supply is connected correctly, but the reed contacts/switches at inputs 1 and/or 2 are connected incorrectly, then the inclusion via internal button can still work. And because you have not mentioned how you have included the SI in your first post, it could have been a source of error.

Please inform Athom about this. The more users report the same errors, the higher the error will be periodized, hopefully.

No, sorry.

You have had @danone and @DirkG working with you so if they can’t help then probably no one can. I have two SI’s work8ng and they are now stable and work every time. But they are not easy. They are complicated.

From reading the above threads I’m afraid I still am not sure what the actual issue is. It would be good to start at the beginning. I had to remove and add them multiple times. And play with the settings often. It probably took me 2 months to get them doing everything I wanted them to do.

What is the primary purpose the the SI you have installed? What use case are you trying to automate?

Hi Peter,

my son is deaf and I need light signalization of various events by blinking lights or strobes in the whole flat. Fibaro implant will be connected to Paradox EVO system with smoke detectors. Also Paradox will be connected to building’s fire system, so where there is evacuation announced thru speakers in hallway, Paradox will know about it.

In case of fire alarm Paradox will trigger INPUT 1 on Fibaro implant and that will start a flow in Homey that will turn on lights in whole flat, activate strobe lights in every room, send notifications, etc. This way my son will know that there is something happening and will go check Paradox LED screen to find out details about alarm.

In case of power failure in the flat, paradox will trigger INPUT 2 on Fibaro implant and that will start a flow in Homey that will turn on lights powered thru UPS, so that there is always some light in the flat - because sign language is quite useless in the dark :slight_smile:

Are there any other (easy) ways how to connect Paradox EVO alarm and Homey, so that fire alarms in Paradox could trigger Homey flows?

Thank you,


Done - they answered “Another user has reported this issue, and it is pending reproduction. I will personally make time to look into the Smart Implant issue as a top priority. I expect this will be somewhere next week.”

So let’s wait and see what they’ll find out. I’ll report here.

Thank you for your effort guys


Update from resseler I bought my Homey from. I have not tried it yet, but I am sending it now if it helps:

Try this with your implant, it worked for us recently:

  1. in implant’s settings → association → Group 1 → the default setting is “1.1”. Change this to “1” and save.
  2. after some while change it back to “1.1” and save. It should start to work.

I’ll try it tonight, fingers crossed.