Fibaro Smart Implant

Can anyone advise me how to set up the parameters on Homey for a fibaro smart implant as per section 4.9 of the fibre instal manual.

In the “Advanced settings” of the Smart Implant → Raw configuration parameters:
Parameter ID,Size,Value (without spaces!)
Parameter ID: 20
Size: 1
value: 2

This means:



1 Like

Thanks very much @antross that worked well. So now I have the question of how to activate output 1 and output 2. Is the only way to press the icon, select output 1 or output 2 and then press the switch? Would the only other way be to have a physical button with two switches? But I really just want to use my phone so was hoping I could just go into the Homey App and press the icon.

Just create 2 virtual devices, name them as you like, and two flows for each of the outputs.

For everyone who is interested in how you can separate the Inputs from Outputs.:grinning:


Great info, Osorkon. Just what I needed to know!

I am still trying to invert the outputs to Normally Closed via 154,1,1;155,1,1 but that won’t work.Any ideas?

Why don’t use the „Output configuration“?
Change „Output orientation“ into „inverted“ and that’s it.

1 Like

That just swaps 1 with 2 and vice versa.

You’re right, sorry, didn’t tried it.
Then switch „Output 1 Mode“ and „Output 2 Mode“ into:

Yes, that’s what I tried and what didn’t work, thus my posting.

You wrote that the raw configuration did not work. You did not wrote that you already tried to change the outputs via the advanced device properties.
I am not a psychic, sorry.
Less information, useless answers…

Do you also confirm the changes by clicking the checkmark in the upper right corner?
Is the change confirmed afterwards?

  1. I am trying to change the OUTPUTS from normally open to normally closed
  2. Using the option in the configuration window “Output 1/2 Mode” didn’t work. Outputs still NO.
  3. Sending the raw command (154,1,1;155,1,1) didn’t work. Outputs still NO.

When u go to and hit Tools/devices, search for the implant. There is key 154 and 155. It says “0” for normally open and “1” for normally closed. I can change the setting in advanced settings in the mobile app and then it changes real life in the developer page. Where do u see “NO” ?

Have you confirmed the changes?
Is the smart implant reachable in the Z-Wave mesh?

I tried that, unfortunately it doesn’t change when I send the raw commands. Anyway guys, thanks for trying to help.

If it doesn’t change when changing the settings in the device then there is something wrong with the mesh network. Did u try to change the setting in advanced settings? So, not with raw commands plz.
If they not change plz put the implant next to Homey (or the other way around) and try again.
In device/advanced settings change the normally open to normally closed, go 1 page back and hit the check sign at the top right of that page. The mobile app also gives a confirmation when settings was stored.

I have a smart implant installed to open my garage door. I use input 1 to monitor when the tilt door is opened or closed. I want to use input 2 to detect if the side door is opened or closed using a similar reed switch I used for the tilt door, even though I don’t use output 2 for anything.

At the moment both input 1 and input 2 get set as soon as I open the tilt door.

Any advice appreciated?

@Rocodamelshekima, I have already asked all these questions and have not received clear answers.

@Peter_Bittner, can’t reproduce it. I have just tested it myself.
Only input 1 reports alarm when I close reed contact 1 (NO).
Only input 2 reports alarm when I close reed contact 2 (NO).
It also works the vice versa, meaning with NC.

Are the reed contacts connected correctly?

  • Reed contact 1 with GND (blue, next to red!) and IN1 (yellow)
  • Reed contact 2 with GND (blue, next to red!) and IN2 (green)


@Peter_Bittner, I hope it can be seen on the video. Don’t get confused, the video will start over and over again.


  • If I close input 1, then output 1 is closed (and remains closed until the video is started again from the beginning).
  • If I close input 2, then output 2 is closed (and remains closed until the video is started from the beginning again).

Sorry m8, I won’t interrupt u again.