Fibaro Roller Shutter 3 - Problems with installing device

My idea is to install a Fibaro Roller Shutter 3 together with my existing (double)switch that controls my sun blind. Without the Fibaro Roller Shutter 3 it works flawless, meaning that one of the buttons bring down the sun blind while pressning the button and the other button does the opposite (bring the sun blind up).

After the Fibaro Roller Shutter 3 is installed it only works to bring the sun blind down, the other button on the switch has no function. The installation of the Fibaro Roller Shutter 3 is done accordingly following the manual, so there shouldn’t be any problems there. Sync to my Homey Pro has worked as well.
When measureing the current on the Fibaro Roller Shutter 3, S1 gives current alternately to Q1 and Q2. Shouldn’t that be S1 → Q1 and S2 → Q2? After removing the Fibaro Roller Shutter 3 the switch works fine again.
Also, it doesn’t work properly with controlling the sun blind through Homey (I can only bring the device down, not up again).

Does anyone have any tips for me?
Se pictures and settings in Homey. Thanks in advance!




Did you read the part about calibration of the Fibaro Roller Shutter 3?

And when it is not working you can try this.
https://community.homey.app/t/fibaro-roller-shutter-3/27653

Or use the search function with Fibaro and Calibration. There is a lot of info.
I don’t use them.

I just tried to use the settings as in the guide you linked to, and then directly started a recalibration. This made some minor changes. In Homey when entering a random % value for the sun blind to be open, eg 20%, it just opens fully. Then when I choose 0% it closes. But I would of course want to be able to choose a % open that actually makes the sun blind stay at that %.
Could this be better with other changes in the advance settings?

Did you also tried what is in the link with the parameters?
I don’t have a Fibaro Roller Shutter 3 at home.
Better then you ask in the Fibaro topic.

Ok, didn’t realize that I posted it in a semi-correct topic. But thanks for trying to help anyway.
Reposted it now!

No problem.

I read this previous topic;

…and used the parametersetting “155,2,2” in the advance settings in Homey. However this didn’t help me, still the same problem both in Homey as well as with the fysical switch.
Any other ideas out there?

This is the Fibaro thread which @Mike1233 meant:

Can’t comment on electrical installation, but just to be sure, you have performed calibration after Fibaro installation, right ?

With the warning that I don’t recommend you to do electrical installation work yourself except when you really know what you are doing, on your image it seems that you have connected Q2 to your switch?

Assuming your wiring is correct, I had the same issue with my Roller Shutter 3, ie only one of the two buttons was working. I had to switch settings to Single Momentary Switch and then back to Double Momentary Switch, after that it worked.

Yes, calibration done after the Fibaro installation. Several times as well :confused:

I haven’t done the electrical installation myself, however a familymember who works as an electrician has done it.
Well I can’t argue that Q2 seems to be connected to the switch. Isn’t that correct? If no, what should it be connected to?

Well, the Fibaro Roller Shutter 3 manual shows that S1 and S2 should be connected to the switch(es) and Q1 and Q2 should connect to the motor. Other wiring depends on whether or not the device is a “standard blind” or blinds with a build in driver.
See https://manuals.fibaro.com/roller-shutter-3/

Once again.a disclaimer: I do not recommend installing or adjusting electrical wiring if you are not sure what you are doing.

3 Likes