[Discontinued] HomeKit Controller

In the same mail you can read it is still possible to work with webhooks to iffff.

Nope. It is possible to trigger homey flows with webhooks from IFTTT. It is not possible to trigger IFTTT applets the other way round. One way communication only.

It is possible to trigger homey flows with webhooks from IFTTT. It is not possible to trigger IFTTT applets the other way round. One way communication only.

Helpful - deleting a post still shows the edit history - if I’d have wanted a home assistant I’d have bought one - unless you are suggesting Athom’s marketing strategy should be to purchase competitor devices also?

I removed my remark because you are only btching and not looking for a solution. I suggested HA because maybe, just maybe this route could help you out. But just posting sht about Athom in a HomeKit controller topic doesn’t help. Good luck with finding a solution, I would suggest putting your Homey on eBay and look for a different solution.

I’m ‘btching’ because I had a solution in a dedicated Athom built Heatmiser app, which then got deleted. I then spent time setting up applets and links through IFTTT and paid for a subscription, now that is also being removed. Imagine say Athom deleted overnight one of your most used apps, then you might understand my issue. I started the conversation asking @TheRealLink whether it would be possible to add the NeoHub and gave him my reasons for requesting it, you then shot back with a comment about using Webhooks which as I understand it is only possible one way. The very reason I posted in this thread was to look for a solution - I don’t understand people like yourself and Peter on the other page guarding Athom’s honour by responding to every negative comment, when actually if nobody said anything nothing would ever change. I’ll await Athom deleting or discontinuing a feature you use daily and await your happy positive outlook on the situation.

Today trying add via your app humidifier VOCOlinc VH1 - but "No ned devices have been found.
Can you add it?
Thank you very much!

@robertklep Do you know what the reason can be that I have to restart HomeyKit app every few hours since a few days? As far as I know nothing has changed in my set up. After the restart of HomeyKit the HomeKit Controller app works again.
Several restarts of Homey didn’t solve the problem.

Update: I saw that I was running HomeyKit 4.0.0 Experimental and did the update a few minutes ago to V4.0.0 Stable. Not sure if this has anything to do with it? :sweat_smile:

HomeyKit 4.0.0 experimental is the same as HomeyKit 4.0.0 stable, so that’s not the issue.

Has it worked previously? If so, and all of a sudden things stopped working, I don’t think the issue is with HomeyKit but with Homey (one of those mysterious “things worked great until they stopped working” issues).

Also not sure how HomeKit Controller factors into this, there isn’t a direct dependency between HomeyKit and HomeKit Controller (unless you somehow use HomeKit Controller to add devices that are exposed by HomeyKit, but I don’t see why you would want to do that).

Thanks Robert for the answer.

I did some test and I can confirm that I have to restart the HomeKit Controller App every 15-20 minutes.
There is no need anymore to restart het HomeyKit app.

@TheRealLink Do you have any idea what is happening and why I have to restart the app every 15-20 minutes?

Hello @robertklep,

will HomeKit be developed further after all? I switched to HomeyKit months ago, because there were many possibilities to assign the device type individually, e.g. to display a socket as sprinkler. But the programmer is very unreliable, so far 1 single update, empty promises for months.

Therefore, I would be interested in whether the app will be further developed and whether also times the possibility will be to assign the device type?

Greetings

Philipp

Not by me.

by others? i sae the update one month ago?

Hi!

I am trying to add a Xiaomi Bedside Lamp. When HomeKit Controller is searching for lights it is discovered. However, after entering the pairing code nothing happens until I get an error saying Timed out after 30000ms. Is this a known issue?

Edit:
I got it to work if I did not pair the device with the Home app🤷‍♂️

Regards,
Erik

same with power outlet VP3… have 2 of them and cant discover it

How do I have to see this? Does this replace my HomeKit setup? Or does it allow me to link a (as in one) HomeKit enabled device to Homey?

To clarify: I have a HomeKit setup in place and I want to keep that as it is.
But I want to add a VOCOlinc device to Homey. Can I add this device to Homey?

“I created an app to add HomeKit enabled devices to Homey.”
“This app allows you to connect and control your HomeKit-enabled devices directly with Homey.”

If you already have the device paired with your iOS devices through HomeKit, you may lose it when you connect it with Homey instead.

Thank you for quoting the lines from the original poster I just read. But it didn’t answer my question.
My question was if the two can exist next to each other. There was a time when you could setup Home Assistant , I guess, as a HomeKit controller, but it was’t possible to also use Apple things as the HomeKit controller. Ergo: you had to move everything to Home Assistant. That is the reason why I ask.

It is fine that I cannot control this particular device via HomeKit once it is added to Homey, but I do need to control my existing HomeKit setup as is.

Well, it does. You just didn’t mention any of this:

That doesn’t make sense, HA’s HomeKit Controller integration only works for unpaired HomeKit-enabled devices, it cannot break any existing pairing between a device and iOS (in fact, even HA cannot break existing pairings between devices and itself after a reset, in which case you need to do a device reset to be able to connect it with HA again).

So this is the reason why i cannot see VocolincVP3 sockets in search for devices… :smiley: