Hello :slight_smile:

I’m a user of the app KomeyKit and I’m really impressed of it but I’ve a little problem.

The app always forget devices I’ve deleted (to not show twice in my HomeKit app).

Have you got same problem, solution for me ? :slight_smile:

Have a nice day,


Sorry to hear about that. The best way for this to get solved is to create an issue for it on Github: https://github.com/swttt/com.swttt.homekit/issues

Please include as much information as possible. For instance, at what point does the app forget which devices should be excluded?

I’ve deleted everything and reinstalled everything to keep you in touch if something wrong happens again !

Anyway thank you a lot for your amazing work ! :pray:


Hi Julien, I have the same problem… It forgets after a reboot for example.
Do you have it solved?

Hello Bart,

I’ve still the same problem… The other problem is that I don’t know when this happens so I can’t give useful information to fix this issue :frowning:

Hello. I’ve a little problem.

I’ve change the wifi password in my WIFI home, i’ve do the homey in recovery mode for change the password and now the homey in connected in the “new wifi”.
But after this, Apple HomeKit don’t discovery the Homey device.

I’ve remove the Homey device in Apple HomeKit and after this i’ve search a new device, but when i insert the code 200-20-200 for search the new device, this not found.

I’ve try to remove and reinstall the App HomeyKit, but is no work.

I’ve a similar problem wen i try with raspberry and homebridge with my older device Vera. If i don’t change the macadress in homebridge, the device don’t have discovering by the Apple HomeKit, because you found the older device( macadress) in memory and don0t associate newly.

Is possible is the similar problem?

Do you have a solution?


strange behaviour of Homey(Kit): Suddenly all devices where gone in HomeKit, Homey was shown in HomeKit correctly without an error. Tried to restart HomeyKit, no success. Tried to restart Homey, no success. tired to delete HomeKit data in the app, no success, tried to give Homey a new name in the App, no success, delete the bridge, the app and reinstall, no success.

Homey could be found, but not connected. Any idea why?


Do your devices show up in the settings page for Homeykit?

Good morning Robert,

yes they do. I also tried to delete a few devices and read them but also no success.

Not sure what would cause HomeKit to just lose all devices, especially if the devices are showing up on the settings page. I also haven’t received any crash reports that might point towards a reason.

Out of curiosity: did this start after your Homey updated to the latest firmware (2.1.2)? There’s a similar issue posted on Github.

Hi Robert,

do not really know when this started, but for sure I have made the update.

I’m running 2.1.2 on my Homey as well, but haven’t run into any issues yet (however, I don’t really use my Homey so the amount of devices it “exports” through HomeKit is rather limited).

Do you think it’s the amount of devices. I have round about 170 devices running…could this cause the issue?

HomeKit should be able to support (much) more, but I never tested HomeyKit with that many devices (not even close to it), so I can’t definitively state that it should work.

Looking back at your initial post, what exactly do you mean with “Homey could be found, but not connected”? Can you post a screenshot on what it looks like?

Well, like I wrote homey could be found when I try to add a device:

In my case I called it Nathan.

Next Step, I can enter the configuration code and then, this:

It’s said: Nathan couldn’t be added. Home couldn’t establish a connection to the device.

Given that you can change the name, I assume that you have installed the beta version of the app. Can you try uninstalling it and moving back to the stable version?

Good evening Robert,

I am sorry, but the reinstall had no effect. Same result then before.
Maybe this might help a bit: I have tried the Atom experiment, this works since an hour.

I had some “free” time today and tried the following.
Delete HomeyKit and reinstall it after a reboot. Then delete every single device from Homeykit, the idea was that Homey and/or Apple HomeKit has a problem with the amount of devices during connection process.

Result: Homey was connected to HomeKit at once.

Now I tried to add on device after another, either I have the same problem again on a certain point or everything stays fine.

There is now one more issue, when I started the there where a few devices with status “unknown” after deletion. After a reboot, a lot of devices where added again but not all. 2 questions now:

  1. Why?
  2. What to do with “unknown” status in several devices?


Unknown devices are devices that are returned by Homey’s WebAPI, but are unknown to HomeyKit. Sometimes this happens, and it might be necessary to increase the “settle time” setting in the HomeyKit app settings.

If you have a lot of devices, it may take a long time before all devices are properly initialized. Since there isn’t an “all devices ready” event that HomeyKit can listen to, all it can do is just wait a long time and hope that all devices have been initialized. That’s the settle time.