[Discontinued] HomeKit Controller

Its approved for testing! Link is in my first post. Please note that this is still in an early development stage. Happy testing!


Hi TheRealLink, thanks for your great work
here are my first testings:


I did some first testing with the Velux Bridge, with 3 roof windows, 3 blinds and a temperature/co2/humidity sensor attached.

It all seems to work, however grouping with the < group > app doesn’t seem to work. The three windows and blinds are next to each other so I want to open/close them all at the same time to the same level.

After using the < group > app it also seems you can’t control the blinds/windows anymore from Homey. First you need to perform manual action on Velux Active App, after that it works again on Homey.

So a few points so far:

  • It seems it’s not giving back the actual opening status of the windows/blinds back to Homey if it wasn’t changed in Homey self, but i.e. from the Velux Active App.
  • Grouping doesn’t work correctly with < group > app. Not sure if that’s a problem in this app, but grouping my windows/blinds is definitely something I prefer. Maybe read the groups from Velux Active gateway itself?
  • Delay in flows when opening Windows - also selecting multiple Windows not possible? ==> not had the time to test in detail yet, still have to do so.

Hey there,

thank you very much for testing. Here are some of my observations:

  • HomeBridge Xiaomi Purifier Pro H seems to reports display capabilities as additional devices. I will try to simulate the device with HomeKit Simulator and report back to you.

  • Version 1.0.6 will add Fan Speed support to Flowerbud.

  • HomeKit Bluetooth devices are currently not supported due some library limitations, will investigate as soon I have a device at hand.

  • The VeluxActive hub is quite… difficult… I checked your reported behavior and could reproduce it. Sadly there is no way I can read or control groups from the hub itself since its not available by the HomeKit Protocol. One thing I also noticed is that the rain detection is not reported to HomeKit as well.

Correct, rain detection is not reported to HomeKit.
For the grouping thing; previously I had it perfectly working in Home Assistant (also via Home Assistant as HomeKit controller) - but with the Home Assistant grouping functionality.

Let me try to do some stuff with the flows and see how that works out.

Also, it it correct that after app upgrade (now on 1.0.8), the bridge isn’t paired with this controller anymore? I need to reset the homekit on bridge again to make it work I believe…

I will look into that

No, the pairing is not affected by the update. If you like, you can send me a diagnostic report. (Settings → Apps → HK Controller)

Flowerbuds are working now. :slight_smile:
It seems changing its colours will crash the app (after 2-3 changes) and results in timeout error. Restart Homekit Controller App will fix until next changes

PM me your address I will send you an cleargrass Bluetooth Homekit devices. :wink:

This looks very interesting!
I’ve tried to add some devices, but without success. Not sure if I’m doing it right.
Will HomeKit devices already added to the Home app be available automatically on search or do I need to pair them again?

Great Work :+1::+1: Vocolinc LS1 :white_check_mark:
next and if this works :kissing_heart: testing tado bridge to add then back to homekit when this works you can still say you bring tado runs in offline mode if tadoserver goes off you can still use the system with other OS than ios . i will report.
I my home this is the last System that must runs via cloud . :crossed_fingers::crossed_fingers:

Hi @TheRealLink,

I have successfully added the Qingping Air Monitor Lite sensor to Homey.
Qingping Air Monitor Lite

There is one thing I do not understand. When adding the sensor to Homey, it will disappear in the the QingPing all. That means that I am not able any more to change screen savers and update the firmware. Do you have any idea how to this can be solved?
I was expecting that the sensor would be available in Homekit as well. So far I understood I have to delete the sensor first in HomeKit and add it via HomeKit Controller to Homey.

Thanks for your support.

As far as I know, Homekit devices can only be paired to one controller.

I don’t know why it would disappear from the QingPing app though, because Homekit (the protocol) doesn’t support firmware updates so there should be another mechanism that it uses for those (like BLE).

The reason why it is disappearing from the QingPing app is because I have to delete the sensor in HomeKit first before I can add it to the HomeKit Controller app. After deleting the sensor there is no link anymore with the QingPing app and therefore empty.

Question is: Do I need to delete the sensor form HomeKit first in order to install it to Homey?

Yes, I understand what’s happening :smiley: it’s just a design flaw in the QingPing app that it relies on a device being paired with Homekit before it shows the device, even though it can communicate with it using a different protocol.

If you want to add it to Homey, deleting the device from Homekit probably isn’t good enough. With Homekit devices, you usually have to reset them before you can connect them to another Homekit controller. How to reset the device is probably listed in the manual.

I will try an other option in the QingPing app.

Thee 1st is to ad the sensor via Homekit to the app. The 2nd is via WiFi to the QingPing app and
maybe it would be possible to add the sensor also to Homey via the HomeKit Controller app.

Update: The 2nd option (connect the sensor directly to the QingPing app) does not work with the HomeKit Controller app. For me now a big question mark how to update the sensor with new firmware and or change settings via the app when the sensor is not available anymore.

The only way left over is to remove the device from Homey, reset it, pair it with regular Homekit, update it from the QingPing app, then remove it from Homekit, reset it, and add it back to Homey.

Yes In know but I do not like this because I have 2 of these sensors. Maybe I can add the sensor in the future via the Mi Homey app. As far as I know is this sensor not yet added to the app. :crossed_fingers:t2:

From what I’m reading on the page you linked to, if you add it to Mi Home you may also not be able to perform firmware updates (“once added to Mi Home,it won’t be exposed it to HomeKit or the QingPing+ app”).

Has this something to do with the HomeKit Controller app or the QingPing app?
If I compare this to Tado… Tas has his own app, linked to HomeKit and available in Homey and on top of this when using the HomeyKit app a 2nd time available in Homekit. :sweat_smile:

I think it’s a limitation of your device (although not being able to add a device to two different Homekit controllers is a Homekit protocol limitation, I think).