Dio App

As usual an own goal by Atom - release a v2.0 of an app and overnight nothing works anymore - all my devices by DIO don’t work and can’t be re-added. Anyone got any advice to revert to an earlier version? Can’t even find the repo on GitHub

You can’t revert to earlier versions of apps, and Athom doesn’t open source most of their apps anymore.

Have you tried a PTP?

1 Like

Yep, removed the app, devices and reinstalled, they won’t even detect anymore.

It’s definitely a moan but I’m so sick of this sort of stuff - do they not test updates before deploying them? Removal of features with no warning is terrible practice - I’ve given up trying to get anything else working with Homey but it would be nice to ensure everything else just kept working. Next step is switch all automatic updates off - something I really shouldn’t have to do.

Something u should have done 3 years ago!

1 Like

Easy to say in hindsight - I lost three apps when updating homey last time as no longer supported. Two more have gone since then. I like to keep things up to date for stability reasons - updates should be properly tested, not just chucked out breaking everything, it’s a shambles.

I only said 3 years ago because that’s when u joined this forums. With 121 days of visits, 178 topics viewed and 4K+ posts read i can imagine u saw this before. But it is something everybody should do. Here we say: if it aint broken, don’t try to fix it. Am running Homey FW version 3.1.5 on a Homey and that’s working like a charm. Now with auto updates enabled u see peeps having trouble. Like with the new Sonos update 2 days ago. Let speakers join another group makes the app crash. So best update if something is broken or u need new abilities. Not update because Athom wants u to!


I’d have to agree. I aways stay a few updates behind no matter what it is. Even apple and Google screw up big time with their updates.

Homey also has had some fairly radical updates to its OS over the last 3 years. One would expect old apps to break… Its the nature of developing tech….

Any app written under SDK3 and is compatible with version 7 should be right for sometime though.


1 Like

Is anyone aware of any other apps similar to DIO in that they allow pairing from a remote press over RF that also allow for Dimmer Sockets? This is something DIO used to do but now doesn’t work.

Difference being when Apple or Google screw up their updates (which isn’t that common - they actually fix them) the last app I reported an issue with got removed from the app list so now it doesn’t even exist - superb

It’s also a shame that most apps downloaded are on auto update by itself. U need to check all apps for disabled auto updates.
But, there is a solution for that also:
Go to the developers tools and fill in this line:
Homey.apps.getApps().then(f => Object.values(f).reduce((r,b)=>Object.assign(r, b.autoupdate ? Homey.apps.updateApp( { id : b.id , "app" : { "autoupdate" : false }} ) : {[b.name]:b.autoupdate}), {}));
After that hit the run button and all of ur apps installed on that Homey will have auto update disabled.

Thnx to @Dijker for the info.

1 Like

It’s a very controversial topic but essentially Athom don’t have any interest in having a universal 433Mhz learning App. I’ve moaned about this a million times. The fellas on here are pretty sick of me by now …:wink:

If you have a few RF devices in your house the best work around I’ve found is buy a cheap SonOff RF bridge and flash it with Tasmota then use the MQTT client App communicate with it… Works extremely well. Will pair with all sorts of oddball devices, especially ones that are proprietary and hard to pair with…

1 Like

Cheers Russell,

I likely will do this, just is an annoying amount of work, for something that was working perfectly 2 days ago.

To put it in perspective I have RF mood switches in every room in my house, each has 6 buttons which I had each setup as a socket using the DIO app (as each obviously transmits a different RF code) and when that socket was switched on or off, it triggered a certain flow. Now all the buttons do not work and can’t be re-added to the app as when using the RF remote copy it doesn’t find the switch transmission. 6 buttons x 7 switches - a lot has stopped working overnight.

For me IOS 15 was a right pain in the ass. :unamused:

As I mentioned before the last 3 years Homey OS has had some radical updates.,. I guess as a comparison try running an IOS 2 App on an iPhone 13…

Also the developers of the apps are responsible for keeping their app’s relevant . I’m no fan of Athom but the Dev’s do bear some of the responsibility. If Athom actually paid them though it probably wouldn’t be such of an issue…:smirk:

Agreed - but normally fixed pretty swiftly.

Not as much of an issue for me when Devs are doing this in there own time, annoyingly the majority of the ones I’ve had issues with have been AthomBV apps, mainly LightwaveRF, Heatmiser and now DIO.

Agree about monetising the store though, compared to the price of major hardware, if the apps worked as well as the flows and software it would be worth paying for them.

Bridge bought, any links you have on the flashing/setup process would be most appreciated - found a few on google but if you have it working well will be worth following that one.

I’ve had a lot of experience with RF., I use it a lot. The best thing I’ve found is to just not rely on an App to make them function , rather just use a really good universal RF remote learning system that just copies the remotes and plays them back.

It opens up a lot of new possibilities. You can buy any cheap RF gear from anywhere and not have to stress wether there is a compatible app for it…

Over the years I’ve found some fantastic cheap RF gear on AliExpress. Some that actually works better than the expensive main brands.

I never have to worry if they will work. I just record the codes, that’s it…

1 Like

Just thinking is this going to work the other way? For receiving as well as transmission?

Although I have some devices I can use to transmit RF to that I currently can’t I mainly need the device to listen out for the RF as a receiver and send a signal to Homey to trigger a flow…

Will give a brief run down tomorrow.

There is a bit involved if your a first timer to Tasmota flashing…

In the meantime lookup the guides on YouTube., You’ll need to also buy a cheap USB to serial interface to upload the firmware onto the SonOff.

There is also an option for you to just buy a Broadlink Pro instead. It would be easy (no hardware flashing) but with the Tasmota / SonOff combo I’ve found it to be a lot more compatible in reading codes from obscure or proprietary RF devices … (not including rolling codes)…

1 Like

Additionally, if someone happens to have the HCS app installed (pro only), there’s a nice central control panel for update settings