Best heating valves in connection with Homey Pro?

I have a Homey Pro 2023 and have about 15 Devolo heating valves (Thermostate) throughout the house. While they connected well with the Devolo smart home control I got some of them connected, but at least half don’t connect despite of multiple attempts. Therefore I’m thinking about changing the heating valves for other manufacturers, e.g. Netatmo, Fibaro or others.

Are there any recommendations for the choice of new heating controllers?

Thanks in advance, Daniel

1 Like

I am satisfied with my Evohome system and HR92 radiator thermostats. All visible and controllable in HP Pro 2023. The thermostats are not directly connected to HP.
Plugwise might be my next system.
Do you want thermostats directly connected to Homey?

Tado is a good system as we’ll.

1 Like

Don’t have any experience with the Fibaro Heat Controller (Z-Wave, FLiRS) and HP23, but with HP19 it didn’t work well. However, since the launch of the HP23, I haven’t read any positive or negative information about the Fibaro Heat Controller so far. So I don’t know if it works well with the HP23.

I use the POPP Smart Thermostat (Zigbee) for more than a year and I’m very satisfied with it. But it only makes sense to use a Zigbee thermostat if you already have a good Zigbee network.

Tado works great!


yes, I would like the thermostats to be directly connected.

1 Like

thanks, I don’t habe anything in Zigbee, would prefer Z-Wave or WLAN. Is there any experience with the Netatmo ones which seem to work with Wifi? I have a couple of Netatmo devices (cameras), which I’m very happy with.

1 Like

For the Netatmo valve maybe check the corresponding topic for other users experience:

I know that some German users uses the Shelly TRV and they are happy with it.

I think the devolo trvs are just a badged version of the popp and the danfoss. On both hp 2016 and 2023 my popp valves were very hit and miss to install.

Even though I have the popp version valves, I install them with the danfoss app.

They are weird to install because you have to put them into installation mode twice to get homey to complete the installation. Otherwise I just get an error.

However. By doing this. I have successfully installed a whole bunch of popp valves for the entire house and they work fine.

I’m guessing the devolo valves will be the same.

The popp valves support temperature reporting and the danfoss ones don’t. However I always found that completely unreliable anyway as they were inaccurate due to being so close to the radiator. So. I don’t miss that function.

I would give the danfoss app a try and uninstall the devolo app. Or disable it when you do the installation.

This has nothing to do with the valves or the brand, this is the standard procedure for
all Z-Wave devices. In the first step the devices were excluded (from the old
SmartHome gateway), in the second step the real inclusion is done.
Athom implemented this procedure some time ago, because many users had problems with the inclusion procedure and contacted Athom support unnecessarily due to stupidity (sorry for thi!). The reason: These users didn’t exclude their Z-Wave device from their old Z-Wave gateway or didn’t reset it to factory settings before.

I’m not sure whether this is the issue with mine, but will try to reset some. If the first step of the two-step pairing is the exclusion from the old gateway, then I get a green tick mark on any of my attempts to pair. The second tick mark does not come though in about half of the cases. And in the cases that worked I can’t see the reason for that vs. the others as all worked well with the old Devolo server.

I tried the Danfoss app but unfortunately without success.

I had several Eurotronic Spirit (Z-Wave) and was finally completely frustrated because of the poor quality (suddenly excluded / seems to eat batteries / 3 devices with a partial display outage just a few weeks after warranty expired). I saw that they launched a new valve, but haven‘t read any reviews, yet.

I changed to Shelly. Yes, they are not the most beautiful ones and the dsplay seems to be designed in the 80‘s but: after 4 months the (embedded) battery still shows >98% and can simply be recharged using a USB-C cable.

Fritz-valves could be a good choice as well if you are using a Fritz Box. But keep in mind: if you plan to implement a window-open-mechanism: Fritz DECT-ULE valves do only ping the fritz box every 15min. So in average it takes 7,5min until a command from the fritz box reaches your valves. If you want this window-open-mechanism, you need to then rely on the embedded algorithm that simply recognizes an unexpected fast decrease in temperature.

Please wait a few seconds after the 1st green tick (exclusion) before starting the inclusion process.
If you include several devices in a row, it may happen that it’s not possible to include any additional devices. Then it usually helps to wait a bit, restart Homey and then continue after 15-30 minutes.

Gosh, this is fiddly. By the way before getting close to calling your customers stupid (see your note on not excluding devices from the old server) Athom should aim to make this things more intuitive and significantly better documented.

I now managed to pair all but two Devolo thermostats:
1.) reset the devices by removing a battery, reinserting while pressing the o button for 10 secs
2.) start the pairing at HomeyPro
3.) press the o button once as requested - the first tick mark appears
4.) while the HomeyPro pairing process now asks you to press the button again, nothing happens when doing it
5.) so I pressed the button longer so that the device moves to “M” mode, then again that it tightens and comes back to life.
6.) the next pressing of the o button then the pairing successfully ended.

That worked for about 8 devices, but 2 still refuse to get paired, the first tick box does not appear under 3.) and nothing moves.

1 Like

Those were my words, not Athom’s!

The inclusion process on my Fibaro Home Center 2 doesn’t explain at all which buttons you have to press and how often at the device. You have to look in the device manual first.
If the instructions about which button must be pressed and how often or for how long are not correct, i.e. don’t match the instructions in the original device manual, please contact the app developer.

Did you follow my advice and restarted Homey and wait for 10-15 minutes?
You can do also a PTP. This is actually the more effective option.
And please check Developer Tools → Z-Wave for Unknown Node (column Device). If there are any, which I suspect, please remove them and then perform a PTP.

I would like to ask if You know some thermostatic heating valves based on wifi, zigbee or z-wave with two import features: fluent regulation (1-100% NOT JUST ON/OFF) and adjustable pressure force (this is for calibration on some older heaters. Thanks in advance.

That is exactly what I had to do. But I managed to add more than eight. I would go into the developer tools and see if there are any devices that have gone wrong.

I’m using set of these: EUROtronic Technology 700201, Spirit Z-Wave Plus Radiotermostat. Pretty satisfied. Main feature I prefered them over, say, Fibaro’s is external temp sensor. In each room I have Aqara temp sensor and updating thermostats room temperature value from Homey. So, in is not affected by an element heat. I did not go with Tado because (as far as I understood) with them I can not control each room separately. With Eurotronic’s I can do it with conjunction with external temp and window/door sensors.

In regard to batteries – agree. Depending on activity of rotating motor batteries are draining in 3-4 months. But not a big deal for me. I’m using rechargeable accums for that. Better than charge from powerbank like single Fibaro termostat I have.

As for periodical excluding… Haven’t faced namely exclusions yet. But when the battery is low, it starts to loose connection. It is true. Then I have a flow that checks if reported temperature is not what was requested. It messages me if it happens and I change the battery. Another issue about battery is its level reporting, which is done, seems, randomly. Some of devices report it accurately, some always show like 15%.

Could you explain how you get the spirit to use an Aqara sensor for maintaining the temperature? I’ve been trying to figure it out but haven’t found it yet