[APP] Netatmo - Same home, just smarter. (by Athom)

This discussion is started to centralize all Questions, Answers and Information around the NetAtmo App for the Weather Station and Thermostat


This topic is not actively monitored by Athom. If you have issues with this app, please report it to support@athom.com, mentioning the version of the app + a good description of the issue.


Netatmo app by Athom

Supported devices:

  • NetAtmo Weather Station with modules
  • NetAtmo Thermostat and Valves
  • NetAtmo Welcome/Presence/Doorbel
  • NetAtmo Home Coach
  • Smart Smoke Alarm
  • Smart Carbon Monoxide Alarm

atm there is no information about upcoming support for the other NetAtmo products:

  • Smart Door and Window Sensors
  • Smart Door Lock and Keys

Known Issues will be posted below.
Be free to ask and discuss anything around these two devices here!

App Contributors

a community member (@caseda) added support for Battery information and the cumulative Rain counters.

Forum Discussion

Initial Discussion created by @GeurtDijker with info from the community
Ask any Moderator to add/update/correct this Discussion.
Updated 20190102.



1 Like

@Bram, looking at the beta of the app some of this information is already outdated?

I copy/paste it from the old forum, will update it asap:)

Does the app have support for the radiator valves or not? I cannot figure that out by reading the info for the app.

I currently have 5 Fibaro Radiator Thermostats but they are not stable so I want to try something else and I prefer radiators that can be included in Homey.

I’m using " Danfoss LC-13 Thermostatic Radiator Valves" with Homey - stabile and works as it should :slight_smile:

Almost week ago Weather station stopped updating its info in Homey (3.0.3 plugin version) i still have all information about temp, humidity etc? on device cards but it’s all outdated.
Is it plugin problem? or Something with Netatmo?
Netatmo native application works fine.

All my NetAtmo Weather Station sensors are still updating over the last days, also v3.0.3.
Just try to Re-pair
(Add an additional sensor, Authenticate, no Sensors Found… )

Everything working just fine over here.

It seems simple plugin restart helped.
Any ideas how to check whether plugin becomes unresponsive? I was sure that it worked fine because it showed latest available data )

There is a device has not reported trigger


Thanks, i’ll try it.

Netatmo Welcome make anyone work with Homey?

Just got me a set of NetAtmo thermostats with a relay. But I can’t add them to the Homey.
I have tried both the stable and beta version.

Homey is on 1.5.12
NetAtmo relay is on firmware 197

So what you tried? what you did?? what it says???

Just shouting its not working ……then its almost impossible to help you ofcourse.

Can say it enough, and wil be saying it over and over.

People of the community love to help others, but its up you for providing every information you got. otherwise it wil be a big gamble

Okay… A bit of a bad mood?
So if I read your comment correctly I will take it from the top.

The NetAtmo is installed and running. Can connect to it through web and see everything related to the relay.
On the Homey I installed the beta first, and then tried to add the relay to Homey. No dice. The device can’t be found. Have tried Using the stable as well which doesn’t work either, as written in my first post.

Is there anything I have missed or are you pleased with the response @RoyWissenburg?

Then why the living h… do you write such an utterly useless response?
Thank you for wasting both of our time.

Please keep out of the conversation if you don’t have any constructive thing to say about the issue.

1 Like

Plz stay on-topic. If u have any problems with anything regarding this forum plz contact a moderator.

1 Like

@akafester Does the login window appear? If not check that popup window is allowed and ad blocker is deaktivated in browser.

I’m using the App for macOS and the window is showing fine and I can authorize at NetAtmo. When the window should show a list of available sensors, the window just says I can close the window. No new devices found.

Try restarting the Netatmo app. Also maybe power off Homey for several minutes.

Here I have no problems adding the Netatmo Thermostat, using the macOS app, too.