[App][Pro] Tuya Cloud

did it work for you yet? i’m having the same problem…

For information: Not working yet. Tried creating a new project on the Tuya IOT platform. Did not work. Tried deleting products in Tuya app and pair again. Did not work. Please help.

@Rick_Delput @Oskar_Skold
Maybe this YT vid I posted earlier helps a bit visualizing things:

Official already. Also tried deleting and adding again but not all items at once, should I try that?


I have used Tuya Cloud before and setup a project and configured the app, but now I am getting this message:




Iot core:

Must there be anything here:

Has my API expired?

I am having kind of the same problem :open_mouth:

You get this message when dropdown is set to legacy or both

I don’t know, but your answer is in your post?

Screenshot 2022-11-20 at 19-11-14 App Pro Tuya Cloud - Apps - Homey Community Forum

About this alert:

The interesting part is when you click on “View exception status” What does that say?

I posted that message about “no permissions” because I thought it was weird.
The other message says the services still works.

But I extended the periode for the IoT core and waiting for approval.
This is the status now, it’s not possible to click on the exception status link :open_mouth:

I can click on the “modify the application” link and this is what’s coming up:


Ah okay. The extension gets approved quite quick, so let’s hope it solves your issue.

I have used the Tuya Cloud app for a while with the official API. A week ago, all my lights stopped working.

Everything works perfectly trough the official Tuya app, and I have tried to delete and reinstall the Tuya Cloud app on my homey. After reconfiguring the app I can’t add add new devices, I just get the “please configure the app” message when I try to add a new device. There was no error code when I pressed “save” in the settings of the app.

Does anyone have an idea of what could be wrong?

Yes, I hope it works when they extend my period :slight_smile:

If you look at my post, do you have the same message at the Tuya cloud project page?

IoT core:

Why am I still getting the message about configuring the app?

Is there other services than IoT core that has to be extended to add Tuya devices to Homey?

When you go to app settings, and press ‘Save’, and you get the ‘Skrill 2406’ error, you can follow this guide:

1 Like

I figured out the problem and this isn’t listed anywhere in this thread as I can see.

There has to be a number here, I put 0. Then the app started working immediately.


Is there any overview of which brands that works with Tuya cloud and Homey?

Odd. It’s empty here

Has anyone experice with Heiman Wifi CO alert?

Is should be Tuya compatible as stated in the questions/comments on Amazon.
I know there motions sensors only providing battery level omn Tuya. So I wonder if this device can send an alarm as device state?

Thank you! That solved the problem for me as well.

I had to extend my cloud service, but the app didn’t work before I added the 0. Weird!

1 Like