[APP][Pro] Synology

Synology DiskStation - The next step in data storage starts here

Adds support for Synology DiskStation

This is not the topic for Synology Surveillance Station 2.
The topic for Synology Surveillance Station 2 you can find here: Synology Surveillance Station 2

Useful links


  • Install this app on your Homey.
  • Go to new devices - Fill in IP - Username - Password
  • Data will be fetched.
  • Check statuses or create flows.

Current features:

  • Switch on / off. (requires Wake-On-Lan to be active)
  • Display CPU %
  • Display Disk %
  • Display Temperature
  • Temperature alarm
  • Display online time
  • Get notification when a value has changed.
  • Flows

Using this app will prevent your HDD from Hibernation. I added a manual update card/button to the app if you don’t want the auto-update.
You can disable auto update in the Device settings

Supported Languages:

  • :uk: English
  • :netherlands: Dutch
  • :de: German (thanks to @DirkG)

If you appreciate this app, contribute to future development by making a paypal contribution
or buy me a coffee on Ko-Fi or Bunq.me

image ko-fiimage

:computer: Apps made by @martijnpoppen

See for more apps link below :point_down:t2: or just open the pull down.



Live version and Test version

Changelog can be viewed on the app page.

To do:

  • [Feature Request] Implement UPS - INVESTIGATE
  • [Feature Request] Implement FAN speeds - IN PROGRESS
1 Like

Frequently Asked Questions

Q0: Does this app work on my Homey?
A1: Homey Pro: YES
A2: Homey (Early 2016): YES
A3: Homey (Early 2018): YES
A4: Homey (Early 2019): YES
A5: Homey Cloud (Bridge): NO (Status: checking with Athom)

A6.1: All old Homey’s are Pro now. (The white ball) Only with less cpu and memory.
A6.2: HOMEY is now a cloud service you can run free or with subscription and a Bridge as a local antenna.

Q1: What is the purpose of this app?
A1: With this app it’s possible to gain insights in your Synology DiskStation
A2: Next to that it’s possible to shutdown and start your DiskStation from Homey.
A3: This app is not meant for Surveillance Station features, There’s already an app for that.

Q2: My HDD is not hibernating
A1: This app calls the Synology API. This will function the same as opening DSM, so it will wake-up your HDD
A2: To prevent waking up you can disable auto-update in the device settings.
A3: To keep getting updates, but minimize the HDD hibernation wake-up you can use the update data flowcard/button

Q3: My Synology doesn’t restart/power ON
A1: This requires Wake On Lan to be enabled in your DSM:
DSM → control panel → hardware & power → WOL on lan 1
A2: Get the mac address:
DSM → control panel → info center → network → Lan 1 → mac address.
A3: : Fill this mac address in the device settings in Homey

Nice, many thanks for your effort. Looking forward to using it. When will it be online?

1 Like

Hey @UA84
Its in review by Athom now :slight_smile:
So I hope next week

1 Like

Thx, curious!
Could definitely use a Synology DS app!

1 Like

New app update (live: 1.1.4 ):

  • NEW: Synology App release

@Henk_Renting @UA84 @RobbertV


Right now it’s basic functionality. I’m planning to add more features. First I want to include DSM 7.



I’m trying to install my Synology. But get this error. it may be due to 2 step verification on my Synology?

That might be. Will dive into that!
Are you running DSM 6?

Edit: You can also create a new user with less permissions. Without 2FA.

Hoi Martijn,

Ik heb hier ook het "probleem"van het "Cannot read property "model"defined.
Heeft dit te maken met het feit dat mijn model niet wordt herkend als model?
Ik kan er op dit moment niet bij maar als ik weer bij kan zal ik het modeltype opzoeken.

Ben heel benieuwd. Lijkt me razendhandige app. Thanks daarvoor.

Grt. Tom.

Hey @TSmit,
Yes debugging right now :slight_smile: (sorry this is the English section of the community).

I’ll let you know once I have a update.
Couldn’t test the app with other users before go live.

yes I run DSM 6, I try to make a new user but when you have admin rights, that user automatically gets 2FA. So I thought I would try turning off 2FA and test again later.

1 Like

Sorry Martijn,

I will continue in English.
If I can help testing no problem.

Grt. Tom.

turned off 2FA but unfortunately gave the same result. so will see if it could be something else. any suggestions to test?

When you disable 2FA on all admin users make sure to disable it for your current user too.
Right top → user icon → personal

Nice find from @RobbertV .
DSM 7 works :smiley:

(without 2fa)
He had the same issue and disabled 2FA.

I’ll search for an way to get data with 2FA enabled :slight_smile:

Does the new user has to be in Admin group ? I have also enabled 2FA…got the same error.