[APP][Pro] Homewizard

If that is the case, you will be the first. I am not running experimental releases so can’t tell.
I suggest you get the mdns browse app for your tablet (see details in this forum) and try to get mdns information visible. If you can see it on your tablet or phone but the Homey script is unable to access then you have to raise a support request with Athom/Homey to hint something in the new firmware is broken.

Hi Jeroen,

1 thing is solved.
I can now reach the host again.
My P1 dongle is in the garage, and 2 floors up i have a ubiquiti access point that differs from my other setup. Weird why the dongle connects to a wifi network 2 floors higher.
But as this is solved, i still can’t add the dongle back to my homey.

As for now i created a virtual device and via homeyscript i read out the dongle and update the value from the virtual device.

In a few days i will see and try if it can find the dongle.

Don’t know if it has something to do with,my setup bug I had updated to the test version 2.1.21 and for 2 days nothing has updated. Last updated 2 days ago. Even changing the temp of the heating did nothing. Restart of the app or the Homewizard didn’t change anything.
I installed version 2.1.16 and when the app has installed, after about 20 seconds the temperature changed in the app from the sensors.
Just to let you know @Jeroen_Tebbens
Homey is on 7.4.1.
Dont know if I had to do more to test.
I use als a Heatlink and Energylink. Both did nothing.

I did change some code in 2.1.21 which is still beta but running it myself and my temperature sensors change fine.

Sent a diagnostic report maybe the log shows something I can check.

I just installed the test version 2.1.21
28e47280-d5f8-43c6-a56c-63f153880565
Will have a look if the sensors have updated. And the Energylink and Heatlink.

Edit: Solved.
Remove and re-add the P1 dongle.
With this script it was not a PITA to fix all flows :grimacing:


Hi Jeroen,

Since today 15:00h my P1 dongle lost its connection with Homey and won’t connect anymore.
First this error:

.
I’ve checked it’s still on IP …15 :

Just now, the error changed to Forbidden.

I restarted the app, Homey & p1 dongle.
Installing app v2.1.21 over v2.1.16 did not change things.

It’s continuous in use for over a year w/o any issue.
The mobile ‘Energy’ app is still connected and up-to-date.
My simple Experia-v10 router is 96hrs online (so no recent changes I assume), I also didn’t change anything in my setup.
Other 2.4GHz devices directly connected to Homey (HomeAssistant, Marantz, LG webOS, Onvif) have no issues.

I can’t think of anything to try.
Hopefully there’s some info in the diag. reports
1st: eb317b90-3859-4b4f-a868-902d43d520b9
2nd: ef612ed5-7380-433e-8fd2-a1de54897415

Homey firmware v7.4.2;
v7.4.3 since 18:44h today, June 23rd.

No hurries! I can live without it :wink:

1 Like

This “forbidden” error is the first time I see that error to be honest.
I assume you didnt disable local api in the app?

Hello @Jeroen_Tebbens after the update till now none of the sensors, Heatlink or Energylink has updated. Only the P1 works good.
This is the report.
9bd3577b-acee-4cbd-89ee-c7f7fe4c48bc
Thanks.

Am really clueless here as there is no ip address mentioned in the log on Homewizard main unit.


---- stdout ----
Error: undefined
--Start Heatlink Polling-- 
2022-06-26 10:57:21 [log] [ManagerDrivers] [heatlink] [feeecb45-9e42-46a3-b73a-75da06ee0354] Gather data
2022-06-26 10:57:21 [log] [ManagerDrivers] [heatlink] [feeecb45-9e42-46a3-b73a-75da06ee0354] No data
Error: undefined
--Start Heatlink Polling-- 
2022-06-26 10:57:41 [log] [ManagerDrivers] [heatlink] [feeecb45-9e42-46a3-b73a-75da06ee0354] Gather data
2022-06-26 10:57:41 [log] [ManagerDrivers] [heatlink] [feeecb45-9e42-46a3-b73a-75da06ee0354] No data
Error: undefined
--Start Heatlink Polling-- 
2022-06-26 10:58:01 [log] [ManagerDrivers] [heatlink] [feeecb45-9e42-46a3-b73a-75da06ee0354] Gather data
2022-06-26 10:58:01 [log] [ManagerDrivers] [heatlink] [feeecb45-9e42-46a3-b73a-75da06ee0354] No data
Error: undefined
--Start Heatlink Polling-- 
2022-06-26 10:58:21 [log] [ManagerDrivers] [heatlink] [feeecb45-9e42-46a3-b73a-75da06ee0354] Gather data
2022-06-26 10:58:21 [log] [ManagerDrivers] [heatlink] [feeecb45-9e42-46a3-b73a-75da06ee0354] No data
Error: undefined

Now I am back to 2.1.15 without changing anything. Only hit the install button.
fbbfa101-edce-482f-b7ab-ec5269dae94d

Maybe it is because I use the adress of a dns in 2.1.16 and that is not working on 2.1.21?

DNS? It should be an ip not a FQDN.

Kind regards / groet,
Jeroen

I mean ddns like joop.no-ip.info to get always to the same ip adres on the same port. My Homewizard is not on port 80.
Sorry for the wrong info.

My last report was there a ip adres in it?
Version 2.1.16 works fine. It uses the ddns of the router.

In 2.1.21 I added an additional layer to check connectivity with the Homewizard main unit as its wifi chip is crap and very very very very very prone to timeouts. There is an additional layer with a library that does a tcp port check which does not allow DNS based names I recon.

Additional layer has hardcoded port 80 check which is default for internal ip homewizard, right so that is why 2.1.21 fails for you.

I have just updated to 2.1.21 and used the local ip adress with my own port fort the Homewizard and that is not working.
With 2.1.16 it still works.

Just like you said above this. It only works with port 80.

Correct its the additional layer that 2.1.12 has which is using the default port 80 for Homewizard.

Maybe I can use a different library for this to avoid custom ports.
Just a need a quick availability check ip Homewizard is available before I start to get the full JSON payload from the unit.

I have no idea from programming. If you say it is possible to use custom ports for the HW I believe you, if you say it is not possible, I believe you also.
If you can make it possible with custum ports that would be nice.
But I have no idea if there are more people with other ports than 80, and use it.

That was probably the cause of the ‘forbidden’ error in hindsight.
When I was testing and trying things,
I disabled the local api and then enabled it again, to see if it would solve things.
When I checked it again after a while, it was back to disabled! Then I enabled it again and made sure it stayed enabled :see_no_evil:

@Mike1233 try 2.1.22 (added check use fqdn and port for testing)