[App][Pro] HomeKitty 😸 (aka HomeyKit 3.0)

I migrated to HomeKitty today and it’s all that I missed on HomeyKit. The list of devices is a great improvement (who on earth thought that enable and disable devices in HomeyKit should have the same color text for adding/removing them :crazy_face: would be a good idea).

Anyway, to give some feedback to improve it even more: sorting. The list looks now randomly sorted. It would be great if it was sorted on room, then device.

//edit: removed autocorrect mistakes

2 Likes

Hi, having some problems with dimming lights on the new app, worked fine with the old one.
Sometimes the first try/tries works fine but not always. After dimming once, it usually failes on the next try, jumps back to last dimming level on the app without the lights changing. After this it dosent respond to new inputs. Is this a known problem?

No, not a known problem, and also quite strange. Please create an issue here, as this forum isn’t very suitable to discuss issues: Issues · robertklep/name.klep.homekitty · GitHub

Please provide as much details as possible (type of device, app that’s used for the devices, and preferably device (virtual) class and capabilities, which can be found here).

You don’t still have the old (HomeyKit) app running, do you? If so, please disable or uninstall it, since running both apps can cause problems in certain situations.

Thanks for quick reply. I have added the problem on github now.
Not familiar with all the ID info you need, so let me know if anything is missing.

Implemented in the current test version: HomeKitty | Homey

1 Like

That is quick! I’ll wait for it to be final, as I am fishing other unstable things and bugs from other things :frowning:

You were the one asking for it… :thinking:

I know, but as I said (and you because you replied) I have issues with Zigbee sensors.
I can only take one step at a time.

Hi Robert, thanks for making this new app! I liked the previous app and I am confident that it will work even better.

But right now I have a problem:
I use it to send commands to my kids through Sonos. The strange thing is that these commands fire 3 times when I press the button in Apple’s Home app. But when I press the button in Homey, the command only fires once, like it should. I have tried several things like resetting the app but it still happens.

To make it very clear to me, I tested this with a new button and a flow that adds a line to the timeline in Homey. When I press the button in Homey, I get one line. When I press the button in Apple’s Home app, I get three lines…

Do you recognize this? Do you have any suggestions to solve this?

Preferably, post your issue on the Github issue tracker for the app, it’s much easier to discuss issues there: Issues · robertklep/name.klep.homekitty · GitHub

Please also include screenshots of the flows you’re using.