Cant get HomeKit to pair with Homey

I can’t pair HomeKit (From iPhone), with Homey using either of the 2 apps available. After scanning the codes, nothing happens, the “wheel” in right corner just spins forever. Anyone knows why?

Try “Don’t have a code or can’t scan” instead of scanning the code. Also, make sure that you’re on the same local network as Homey.

Is this the first time ever that you are trying to connect HomeKit with Homey?

Have tried, same result. Have also tried rebooting phone and Homey. Yes, I got Homey yesterday.

Do you use a HomeKit hub, like an AppleTV or an old iPad, in your network? And both Homey and your phone are logged in onto the same WiFi network, I assume?

Yes. I use Apple TV 4. Yep, same network.

For iOS to be able to find Homey, all parts of your network need to support multicast properly. That’s typically not something that you need to configure, but because iOS consistently can’t find Homey, even for a fresh install, does seem to suggest a multicast issue.

Does your Homey have a static (fixed) IP-address in your network?

I went into router config, and Homey`s “settings line” was red. I put on static ip and Rebootet Homey again. Now I can find Homey in HomeKit after clicking “type manually”, but still no response after typing in code.

Also, my other components that was already in HomeKit, now displays “no response”. Maybe because I have added them in Homeys app?

It works now! I dont know what the issue was. But after another iPhone reboot, it connected. Thanks for the help! :slight_smile:


I was going to write that in my experience, HomeKit can easily get confused. For me, it usually works again after turning WiFi off and on. Sometimes a reboot of my iPhone is necessary (as you have also experienced).

Same exact issue here, juste received my homey.
Homey rebooted and iPhone rebooted but no result.
Input code by hand but no success.
I removed homey from home kit app in homey app ad added again, no success.

When I load homey in homier app as device I got this error but the device is included

Try the Homeykit app.

1 Like

I’m probably late to the party but I have tried above mentioned solutions but none seem to work. HomeKit just isn’t able to find homey.

Any other solutions out there I can try?
Thanks in advance!