Homey and Apple Homekit - not connecting

Hello Community,

I need your help…had the Homey Experiment “Homekit” activated since available. A few days ago Homekit tells me, that Homey is not responding anymore…

I thought: Okay, why not, deactivated and reactivated the experiment and tried to connect Homey again. But HomeKit say “can not connect”

No problem, maybe an issue with the experiment, i thought so I downloaded one of the long working apps for HomeKit, but even they can’t connect.

Does anyone has an idea why and what to do?

Regards
Andreas

Did you get this werking again? My Homey Pro doesn’t connect to HomeKit so maybe you have my solution.

The following trick worked for me with Bas Jansen’s HomeKit app:

Go to the Homey Settings-Page and scroll down to the App-Settings for HomeyKit.
Delete all devices, except one. Now connect Homey and HomeKit.

After the connection is made, add one device after another again - I added one and waited for it until it appears in HomeKit.

Til now there are no issues anymore. I suppose that HomeKit has a problem with to many devices when the connection is established for the first time.

Regards
Andreas

2 Likes