[App][Pro] HomeKitty 😸 (aka HomeyKit 3.0)

Thanks, that is how I have it now but if there’s a way to just use the geofence triggers directly it saves the extra steps

1 Like

Geofencing is something that happens on the phone itself, HomeKitty is unaware of your location. So you’ll need an automation. Instead of a virtual device you can also use HomeKitty’s “Flow Starter” device.

1 Like

Thanks Robert, appreciate your response.

I was afraid it would be impossible to directly act on these triggers.

Tried the flow starter device and it’s nice but a button (needs to be a switch for it to work properly). Maybe add the possibility to either create a button or switch? Although in the end it won’t really change the mechanics needed, except for potentially removing the need for the Virtual Device app… if you don’t use the more complex devices such as curtains (sliders etc)

Ah yes, a switch makes more sense.

The Flow Starter device has a specific reason for existing (just using a regular virtual button causes problems with flows triggering multiple times) but for a switch a virtual device is just as easy to use. I don’t have plans to add a virtual switch to HomeKitty in the foreseeable future.

1 Like

Hi!

Some time ago, I described an issue I experienced with the Homeykit after a Homey update. My Aqara and Shelly devices were removed from the Apple’s Home app. It looked as if they were deselected on the Homeykit device’s list.
Just after, I moved to HomeKitty. Everything works really well but I just realised that all of my Shelly 2.5 devices disappeared from Apple’s Home app again (as if I deselected them even though I didn’t and they were not deselected). I can see that the Shelly Homey app was recently updated. Could there be a link between those 2 events? It was enough for me to deselect those specific devices in the HomeKitty app and select them again so not a big issue.

There could be, although it’s strange that a device doesn’t show up on iOS but is still selected as being added in the list of devices. Without more information (like a diagnostics report) I don’t know how this can happen.

Is this a generally better solution for HomeKit and homey cooperation than Athom’s own HomeKit experiment?

Certainly!
Not only in functionality but also in support when you have questions or remarks.

1 Like

@robertklep after the latest rc, in wich some networking is changed from athom’s side, homekitty can’t connect to homekit anymore. If you need a diagnostic report or something let me know😉

Already posted v2.1.0 (current test version) which should solve the issue.

You’re the best👍🏻 everything works again.

1 Like

When Homey reboots Homekitty always set the Qubino switch in a default room. And can’t switch the device to another room in HomeKit. I have to restart homekitty, publish and unpublish the device in Homekitty.

This happens when HomeKit (iOS) thinks the device is new. If it just happens with Qubino devices, I’m inclined to think that this is due to something in the Qubino app.

Yes only with Qubino. All others are fine. I can’t even move the device to other rooms without toggling some settings. Like restarting Homekitty multiple times or publish and unpublish the Qubino device.

No, it happens also with some (!) Fibaro devices (e.g. Walli Roller Shutter, Walli Switch, Double Switch 2), POPP devices (Smart Thermostat) and virtual devices from the Device Capabilities app.

Fibaro, Qubino, POPP are all Z-Wave devices :thinking: (and plenty of people are having issues with Z-Wave on HP2023)

Device Capabilities is an app that depends on other apps which could cause delays with device initialisation which, in turn, can cause issues with HomeKitty.

Bit of background: when HomeKitty is started within 10 minutes after a reboot, it will start a loop where it checks if new devices are still being created (by other apps). Once all devices have been created, and are marked as ready, it will start the HomeKit bridge. At that point, iOS can connect to it and it will receive a list of devices. If iOS recognises these devices, there will be no issues.

However, when apps/protocols have their own delay and create their devices at a later point, or when apps change devices (add/remove capabilities), HomeKitty will add these devices to the bridge and iOS will think they are new (iOS is stupid in that respect: even if a device gets added with the same id as previously, it will still not recognise the device as “seen before”).

The POPP Smart Thermostat is a Zigbee device, but it’s the same app of course.
I understand the background and why this “problem” may occur. But what I don’t understand is that not all Fibaro devices are affected. It’s always the same Fibaro devices that are added to the default room after a Homey restart in Apple Home. Is there also an explanation for this?

Perhaps they have a delayed initialisation, I don’t know.

Feel free to send a diagnostics report next time you’ve rebooted Homey (but after the devices occur in HomeKit, so we know that HomeKitty has started), perhaps I can find out why it happens with certain devices.

1 Like

I also have problems often when Homey is rebooted. I have to rearrange almost every device.

@robertklep When I create a Flow starter device, it is not showing up in HomeKit, all other devices that I want to expose to HomeKit works fine, even with the app Virtual Devices, the flow starter device is not even present in the settings app like all other devices. I know it’s in beta, any idea?

Anyway great app!