After each update all Time-based flows are incorrect

After each firmware update all the time-based flows are not triggered at the correct time.
This issue already persists for more than a year.
Rebooting Homey solves the problem.

Anybody else have this problem?

Yes, this happens to a lot of people. Athom apparently is unable to solve this issue.

I would say this is a high prio bug even if a reboot helps. If firmware updates are pushed at night, and Homey has alarm clock features (among others) it has significant impact on users. All those that are affected should put in a support ticket at Athom to make sure they are aware of the impact.

1 Like

I must say I haven’t experienced this.
I have several time based flows to do things like arm the house alarm at midnight, disarm it in the morning (with other conditions), open the curtains in the morning, etc.
As I’m the aatp group my homey updates quite regularly and I have never had a problem.

When you have the problem, is it offset by a certain amount of time?

In my experience, people that have this issue report a one-hour offset. I think it’s either timezone or DST related. Another solution is usually to change the location setting of Homey in the app to some random location, and then put it back to the correct location again.

This issue was introduced in the firmware where SDKv3 was introduced, where (SDKv3) apps are run with a UTC timezone.

1 Like

indeed, there is a one (or 2) hours offset of the flows.

I notice this, as for example, I have a flow to start my hot water boiler at 0630, and then it will not start after an update.
As a temporary solution, they could make a trigger ‘homey update’, so I could make a flow: after update reboot Homey (again). But this is just a fix which doesn’t fixes the core problem

Hmm, does sound like a timezone issue rather than DST. I’m on UTC with DST and as I don’t see the problem I guess the DST is not the issue.

My location is manually set, also b/c the geofence function only works OK that way.
I never had issues with flows triggered by “date & time” cards or any other time driven trigger.
Edit: After any update that is.

Perhaps it only happens for people using automatic location detection?

Nope, I have manual location detection.
(Auto = location of my ISP)

Just 2 b sure, do we all mean this setting? And set the pointer to your home location on the map?

And like @robertklep says, setting the pointer to f.i. New York and then back to your home location should solve the time issues

Is there a solution?

I’ve restarted and reset the location but some flows won’t start on timer anyway.

Keep telling Athom about it (support@athom.com) in the hope that they will give some priority to this issue (however, my guess is that they can’t reproduce it, hence it doesn’t exist…)

I have a flow that starts every hour between 8-14 o’clock.

Since about 5 September the first run is at 9 not 8.

I have tested and found the same behaviour if I start a flow every minute between certain times. It skips the first minute.

Same after a reboot.

I’m on UTC+3

I’ve notified support

News: my weekly test of this shows that it seems to have been resolved after I opened a ticket. I’m now on 7.1.3

Of course, we should probably wait for the next firmware update and test again. Please confirm if this is working for you too?


Since last night on 7.1.4

All good.

No, not this issue:

IMG_3214

This morning my test flow was triggered twice, at the correct time and 59 s later.
I’m on 7.1.4.

Thread almost in German and a little bit in English and Dutch, sorry!

@fantross What is not working? How many times do you expect your flow to trigger (AND part of the flow)?

See below the screenshots and the notification.
Time between 11:25 and 11:27 triggers twice: at 11:25 and at 11:26.

You may be right, in my case I should probably get 3 notifications, not 2


I apologize, I seem to have misunderstood you.
The problem I and other user have is slightly different, but it also has something to do with homey time.

The flow should be triggered for example at 06:15:00 o’clock in the morning. But the flow isn’t triggered at 06:15:00 o’clock, the flow is triggered at 06:15:59 o’clock.
I updated the screenshot in my other flow, please have a look on it. And in this special case, the flow was even triggered twice. Once at the right time and once 59 seconds later.

This is the relevant flow:

Translation:
When…
– The Time is 06:15

And as I said before, this happens with several users. The flow is always triggered exactly 59 seconds too late.

This particular issue is confirmed by Athom and hopefully fixed in the next firmware release.

1 Like