Time based flows not correct

After a reinstall I have issues with my time bases flows. After some days of logging I see that my Homey triggers the flows one hour to early.

As I can see in the developer settings the time is not correct.

Anybody an idea to change this?

Try changing the location (more… -> settings -> location) of your Homey to manual, then back to automatic.

With me they came on an hour too late.

Following the tips here I pulled the plug and that did the trick.

Strange, just did it a couple of times, but now it worked…