Help a newbie out?

Hello! :slight_smile: So i just receantly purchased my first Homey device…a Bridge, after having used Telldus Netstick for a couple of years. I paired it with a simple outlet and so far no problem. To that outlet i connected a simple lamp which i then turned on and off as i pleased using the Homey App. But when i decided i wanted to schedule what time it stayed lit i ran into some problems. I created a flow, chose lets say 1:10pm as “when”…monday to sunday as “And”…and activate said outlet for “Then”. When i then tested the flow it most certainly turned on the lamp. Just as it turned it off when i tested the flow i created for deactivating it. But then when the clock strikes the hour when my automation should start or/and end…absolutely nothing happens. What am i doing wrong? :weary:

Hi Andreas,

Can you share (screenshots) of your flows?

Is Homey’s local time correct (like, does the flow trigger hours earlier or later)? → Goto and look for dateHuman:

I always add log cards, like timeline notification cards, to flow actions, so you can discover if the flow got triggered or not, and if it was triggered, your device is probably not responding.

Especially when starting with Homey, and your flows don’t act like expected, first temporary leave out the AND cards to prevent unexpected behaviour.
I.e. when you use “AND it is between Monday and Sunday”, that is equal to ‘every day’ isn’t it?
But when you accidentally reversed the card, it says “it is not between Monday and Sunday”.
For this, add an ELSE timeline notification.
When you drag a card down, the ELSE option becomes available

Thank you SOOO much! :smiley: Homey´s local time was NOT correct. I works like a charm now that i´ve corrected the “When” accordingly . I was about to give up on this thing had it not been for your help. :sweat_smile: Is there a way to change the device´s local time?

1 Like

For me a restart did the job after homey lost its correct time, also look in settings—> location if your location is correct, because if it isn’t this can give you problems with your timezone.

In addition to Glenn’s hints, and your location on the map is correct, temporary change your location to an other timezone.

Example, I just zoomed out and moved the location pin to the USA.

Looking on the developer page again, the timezone has changed:

Now move the location pin back to your hometown, and the timezone (and dateHuman) should be correct now:


Yup, that did the trick. Thank you so much! :slight_smile:

1 Like