Time offset problem in Homey

I’ve several flows based on time, I already noticed for some days there was something strange going on. So first I checked if the system time of Homey was ok. No strange things there. Later I made a flow sending a Telegram message: Time is now “time”, then I noticed the “time” was two hours earlier than it actually was. Maybe it’s based on region, but I couldn’t find a setting for it.
Does anybody have any idea what’s going wrong?

Is your location set correctly?

Yes it is, did move the pin on the map a bit to make sure it grabs the location again. Unfortunately this wasn’t the solution.

Is your time zone 2 hours different to UTC / GMT?
Does the problem just show in Telegram?

JSON time is normally UTC so it is possible that the Homey app is sending that but the Telegram panel is not converting to local time.

I’m living in The Netherlands, so indeed UTC time is now two hours earlier (Google told me). It’s not only with Telegram, it’s also with turning my lights on/off, that’s how I noticed it. Do you have an idea how to use the local Dutch time in the flows? It was working flawless before.

Is the wrong time shown in the flow editor as well?

I assume you’re using a token to insert the current time.

Yes, here as well

What about https://developer.athom.com/tools/system?

Wrong time, right timezone…

date is OK as it has the Z on the end so that it UTC. However date-Human is wrong as that should be local time.
Strange that your dateDst is false but Roberts is true.
Might be one for Athom to check.

Also, have you tried cycling the power for Homey?

Check if the time on your router is correct.

Time of the router is correct, also router has the correct time as NTP server.

Can’t reboot Homey otherwise I can’t control my 433MHz devices for more than 24 hours because of this

I agree that it’s strange that dateDst is false.

1 Like

Nowhere read that a real PTP (power off for 15 minutes power on, wait 30 minutes) is done, only see “reboot” for ever what that means?

dateDst should be TRUE, no idea where to set this.

1 Like

PTP like suggested did the trick, time is correct again and dateDst is true again. Only issue is that I can’t control my 433MHz devices now for at least 24 hours, but this issue is solved. :smile: