Aeotec Multisensor 6 - Strange minus readings on Luminence and UV

Hi All,

I currently have two of four Aeotec Multisensor 6 units which are showing very strange readings such as -32,768 luminance and -1 UV despite being in sunlight or lit rooms.

The sensors are located close the Homey and similar distances to the two working sensors (appear to be correct readings).

I have tried to remove the device and re-add, however, this has made no difference.

Is anyone able to help? Are the sensor units dudd?

Thank you in advance and I look forward to hearing from you.

Are the MS 6 battery powered or by USB? If they powered by battery I would change the batteries first.
Otherwise I would suggest to contact Aeotec, because it’s probably not a range/connection problem.

Thank you Fantross!

They are all POE-USB powered. I am unsure why only two are showing odd readings.

I have 3 as well. Both 3 never update the UV parameter. Maybe there is an issue in updating values? 2 are directly usb powered and 1 usb poe powered.

And you did that VERY close to Homey? ( < 10 cm )

Thank you for your replies.

I removed and re-added within 1.5 to 2 metres of the Homey hub. I can try again tonight, but I suspect this will not make a difference.

Limited range during pairing

Warning: While pairing, a signal cannot ‘hop’ across the network. Also, for security measures, some devices pair in a special low-powered mode. This makes the range of that Z-Wave device temporarily small, to prevent malicious actions.

Always pair Z-Wave devices close to Homey, then place them in the right place. Within 30 minutes, the new network routes will be automatically established, and the device will become active.

Have you checked the settings of that device? Maybe the are set to “Ultraviolet Threshold = 0”, which means they send no UV reports at all.

Thank you for your posts. I did not have the chance to check last night. But will do this evening.

UV Threshold is set to 2. Luminance threshold is set to 2 and Temperature is set to 2. Temperature readings appear correct.

Only the UV and Luminance are the issue. I will remove the device tonight and add again in close proximity to the Homey Hub. Hope this will work.

Jan tnx! Settings is on the default 2 :wink: so that couldnt be the issue

Do you have the latest firmware V1.15 installed on this multisensor device?

From the release notes for that firmware:

V1.15 Changelogs:

*** Fixes Light Sensor reporting abnormal values on occasion**

This firmware was released 28 september 2021

I did not install it because mine is reporting UV correctly.

1 Like

How do you install a new firmware from Homey?

1 Like

Just updated the software. Now wait for daylight. I will give you an update. Only problem now is that it seems to not include anymore in as secure.

Still no update on UV with latest firmware

Judging the lux value, that sensor is inside, inside is a terrible place to measure UV as there is hardly any of it inside even if you would place it in the sun behind the window.

1 Like

You’re absolutely right, but it doesn’t explain the strange values mentioned in the first post:

0 UV inside the house is absolutely ok, but -1 UV?

Black hole nearby?

Yes, -1 could be possible, depending on how the UVi (UV index) is calculated, as it is just a calculation of an analog value (that starts at 1 volts or something like that).

and -32768 as value means “invalid value”, still not very explanatory, but that’s all there is to it.
It could be just a badly iniated sensor, or bad firmware, but hard to say.
You could of course ask the developer of the devices and app (Aeotec) themselves, they probably can say more.

This was my suggestion in my first post:wink:

That strange value is not visible anymore, probably because @HarmJ re-added the device very close to Homey.image