Aeotec Multisensor 6 Gen 5 not reporting Lux (often), Hum and Ultraviolet

I just bought myself a new Aeotec Multisensor 6 device. I’ve installed the Aeotec application and added it to homey. Motion and temp sensors work greag. Lux doesn’t change that often, even if its lux 0 and I turn on the light, it just doesn’t change, it does have a value, but just 0.

Humididty and Ultraviolet don’t change at all. They don’t even have a value.

I have the sensor USB powered with a IPAD charger, which should provide enough power, right?
I have included it insecure

Altered the settings to have it reporting with the minimal change (mostly 1, because 0 is no report) and changed the reporting interval to 5 from 600.

Is the device just broken?

Using 5.0.0 RC 49 for homey and 3.0.4 for Aeotec app.

Is there a different way to check if it is a app versus reporting error? Access the device through cli for instance.

Maybe wait untill tomow ?
UV never showed me another value then 0 but maybe that’s because it’s not in direct sunlight.

Have you added it secure or insecure (I assume there is the same setting with HA).

Not secure.

But the hum does report with you, right? What kind of USB adapter are you using? I cannot imagine a 2.1A output isn’t enough. But tried with a 0.5A too and while it does work, behaves exactly the same.

Which version of app are you using? I tried with the stable, but that won’t even include the device (I removed it to do some testing).


Right, now I included it for the second time (in the sable app I cannot add it btw) and now it does have values with Hum and UVI (indeed 0). But now it doesn’t report on motion…

Right, second time adding and now everything seems to work… weird enough