Aeotec Home Energy Meter Gen5 - 3 clamp


I’m using the energy meter mentioned in the header (HEMG5) with the app forked from the old official version of the Aeotec app, made by @KevinLe. Thanks Kevin for that!

The problem with the unofficial app is following:

  1. I can’t use the latest official Aeotec app for other Aeotec devices, so basically new devices from Aeotec can’t be used.
  2. The unofficial app is not updated to Homey 3.0.0 energy functions, so the Homey energy page show also the sum of combined energy measurement and separate clamps and all other energy measurements I have. So basically the energy display is useless.

How this can be corrected:

  1. Best option would be to make a pull request to the official app
  2. Second best option to update the unofficial app, but in that case the problem number 1 still remains.

I would like to fix these issues. I have tried following:

  1. Contacted Athom with the request form. Futile.
  2. Contacted @KevinLe, but no luck with that.

So next option is that some other developer willing to spend some time with the problem. I’m putting 20€ bounty for the developer that get’s this supported by the official Aeotec app.

Hi peltsi51,
I and @KevinLe are planning to update some of Aeotec devices that use energy measurements.
I will update and notify you after the biggest holiday time in my country ends.


And Happy New Year.

Good to hear that things are going to be set in motion with the Aeotec app. I assume that you are going to update the official app?

I have a small update to 3 phase, please follow and download at GitHub , This will be where the app will be updated .

Fw 3.0 onwards, I don’t know which library Athom updated, I debugged, the clamps still got status, but didn’t update on the interface. Therefore, I have temporarily added a pollInterval function to update this status on the interface.


1 : Remove Home Energy Meter Gen5-3 Phase
2 : Remove Aeotec Application by @KevinLe
3 : Install the App
4 : After installing the application and pairing with HEM, please re-power HEM (all this needs to be done).

  • Note :
    -Please wait 30 seconds to report the total update and 1 minute for the clamps.
    -If you are running other Aeotec devices, please do not delete .
    -My house is not running 3 phase electricity, I cannot test it correctly.
1 Like

Thanks @BaoTran for the update. I’m little afraid of updating the app, because there are dosens of flows that need to be rewritten. But I will try to get the time to do that at some point. Couple of questions though before:

  1. You wrote that clamps got the status but didn’t update the values? If I remember correctly the clamp values don’t update on default setting, but you have to change the “Association group 1 report type”-setting accordingly. Could this have been the problem?
  2. What do you mean with the poll interval? In which values the poll interval is? Is it continuous or only at the initialization?
  3. Are you planning to contribute to the official app of Athom? Or is this even possible anymore to make pull requests for the official apps?
  1. I have debugged on the CLI (command line), the status of node 0 (Total report) receives the status, but the nodes 1,2,3 (corresponding to clamp) do not capture the status (I added the poll function) . I have calculated the values for the groups (spreadsheets) and added the defaults in the settings (you do not need to reconfigure), and it all worked.

  2. It works continuously, every 30 seconds to 1 minute it will automatically update the status of each kep.

  3. Previously contributed bug fixes and some more devices in Github Aeotec, but it took time to approve . I am currently a distributor of Aeotec and Homey, I have many customers and agents who are using my application, and they have been running smoothly so far without any errors. So I will update the application constantly when there is a new device or error. Homey Firmware update coming, will fix zwave and zigbee errors.

first thanks for updating the app for the home energy meter with 3 clamps :+1:
i installed it according to the instructions and it runs perfectly :heart_eyes:
i would have a question.
in the energy tab under the menu item smart meter, if I select the hem (home smart meter) I can use the gear on the top right to set whether the hem should be included in the total consumption.
could you please also add this setting to the three clamps?

How do i install the app?

Here is a good tutorial on how to install apps: [HOW TO] CLI install method It worked like a charm on my Mac and using the terminal exactly as stated in the tutorial.

Two issues:

  1. When downloading the app as per instructions from BaoTran and keeping the original Aeotec App, the HEM gen 5 gets installed under the Aeotec App - even if I add the HEM under BaoTrans App! I realize this sounds crazy, but temporarily disabling the Aeotec App while istalling the HEM under BaoTrans app did the trick.
  2. Haven’t checked out carefully or long, but only Clamp 02 seems active. Will click around a little (but really don’t know what all the settings - eg Association group 1-3 report type etc - mean). Any clue if/what is wrong? Any setting that should be changed? As I understand from BaoTrans reply above, no changes from default should be needed?

Lastly: big thanks for the App! Feel many users are left out - any progress to include in official Aeotec App?


I have installed the Aeotec app. I have the HEM Gen5 single Clamp (One phase). I tried adding it but the process keeps on failing. in short I am not able to add it. Says try again later…

Did anyone face a similar issue? Is there a workaround?


please try an alternative app download directly from AEOTEC (no from Homey). They pay attention when you clip you clamp to the wiring. It must be proper direction. Here is the manual ho to do it. The main text is provided in Slovak language - but combined with English and so should be workable for you–>

Cheers Marian

In your link, it specifically says it supports the 3 phase version, and not the 1 phase one

Hello. Did you have the chance to add the HEM Gen5 1 Clamp?

Thank you for the app!
How can i reset the total power readings?

Check the manual for device (and I don’t recall exactly, sorry)…it’s not linked with app.

The manual reset (press button for 10 seconds) does not reset kWh reading.
This is the only thing i found on Aeotecs website:

Maybe this can also be somehow added to Homey app?

Link to the advanced manual

…you may want to try with “2.Reset to factory default setting” with RAW ZWave parameters then.

1 Like

Hi Crimly

See z-wave send raw command, disregard Fibaro.

There you go :slight_smile:


Hi BaoTran.
I’ve been stuggling a lot with adding the HEM 3 clamp, but cannot make it work.
I have installed the app. The HEM 3 phase is there. I select it but anyway HEM (2nd edition) is installed (pic).
In the settings page (pic) there are differnt lines for clamp1, clamp 2 and 3.
Tried to delete the original Aeotech app but then a zwave generic unit is installed.
Tried to disable the original Aeotech app but then a zwave generic unit is installed.
Tried reinstalling both Aeotech app and the app. Repowered HEM after installation.
No success.
Homey and apps are always latest updates.
Any ideas?

Are you sure there is an alternative for 3 clamp version? On the app page it seems like it’s only (two versions of) the 2 clamp version that is available.