Zigbee routes gone after upgrade to v5 rc38

Hi @rvdeijk

It’s been more then a week so don’t think that will work for me… :frowning:

Hi @Igy

I’ve waited for a week so maybe I’ll reset it tomorrow and see if that works.
I only have 12 Zigbee devices so far, so not that much work, just some flows to rebuild after…

Thanks.

Did you manage to get your Zigbee routes showing again? After the v5 update, my routes are gone. I’ve done numerous restarts and waited for more than 15 minutes before powering on the Homey, all without any result. The routes showed perfectly before the update.

This week I’ve also added 3 new devices (that is a few weeks after the v5 update). Initially the new devices had route information (they all connected to Homey directly, even though there are two router devices much closer). After a few days, their route info also disappeared like all the existing devices, except for one sensor. Very weird. The devices do seem to function normally though.

You need to do a zigbee reset. read the forum posts about new 5.0 and zigbee reset…

Thanks for the reply, but it’s not really helpful when you just say “read the forum posts”. That is exactly what I’ve been looking for and how I ended up in this topic. The forums are a confusing mess with no real help from the Homey guys themselves. I love my Homey, but the support is terrible.

This is a community forum. If you want to contact Athom about any issues, you have to file a support request through support@athom.com

Robert, I’m well aware of that, thank you. I pointed out that in a “community forum” as you put it, it is not very helpful of someone to point you to “the forum”. It would’ve been way more helpful if someone would’ve pointed me to the actual post or posts where the issue was addressed.

Specifically for routes not showing up or disappearing, this thread is where that issue is being addressed.

Hi!
Got the same issue😩…
Does this issue affects users who have a lot of zigbee devices?

Under V 4.2 i had to wait more than 15 minutes to get the routes, but now with V5 I have waited for 1hour, but nothing appears…
I have tried Ptp, restart homey without success…

I’d like to avoid resetting my zigbee network as I have more than 50 zigbee devices and hundreds flows…

I hope this will be solved soon…

I guess the main question is: do your Zigbee devices still work? If so, I don’t see why it matters so much that the routes aren’t being shown.

For some people, it took more than a week before the routes were showing up.

Yes, it works quitte well excepted 2 devices,… that’s why i’d like to see their routes🤗.

Exactly, it is supposed to work. My devices function normally most of the time, but now and then one fails to register an activity. It seems like something is wrong with my Zigbee network after the upgrade to v5, because (some of) the new devices I added do show routes, but they connect directly to Homey and not via their closest router.

What I find very disappointing is the way some people react in the forums. It is as if they find it more important to play police man and to constantly try and correct other people, instead of of actually being helpful.

That is the same as when people talking, there are always people that don’t have anything to say, but they still talking to impress others, my advice is, ignore them, and certainly don’t answer them, they will keep talking/writing.

@Yann_Yann and @andrekrit Check this topic:
fixing-disconnected-zigbee-devices-without-having-to-modify-all-flows

Once you did this, you could also check your zigbee health with a script

I had 8 devices that lost their route and fixed them without resetting the zigbee or change flows.

Thanks for the directions @rvdeijk

I ran both scripts @Dijker created (thanks Geurt!) as my zigbee developers page stays empty (been like that for weeks, since stable v5)

The script returns:

Oddly enough, zigbee works…I just have huge cpu spikes which (I think) causes my Homey to become unresponsive / go offline.

I will re-add a router as ‘duplicate’ and see if that does anything. If not, I will have to reset zigbee and rebuilt my flows.

I have absolutely the same situation since update to v5. There are only Aqara sensors and not a single route is shown. Strange that ALL zigbee sensors seem to work properly.
I added two Osram Smart+ plugs as routers but the situation stays the same. Also the newly added plugs have no route information.

Please let me know if you find a solution which does not mean a complete reset of zigbee.

I decided to reset mij zigbee network. After that, I added all 4 routers first, and end devices later.

The good news?
In developers I see all devices and the routers are ‘routing’.

The bad news?
I had hope that resetting zigbee would finally solve the cpu overloading (often >200% and losing wifi connection to Homey). That is still happening :frowning:

I have contacted Athom support and they are looking into this case. Hope to hear more on Monday.

I finally reset my Zigbee network, too. It was much less work than expected.

  • connecting new devices to v5-Zigbee works a lot faster than before
  • most of my Zigbee devices are (Aqara) sensors and in my flows I use groups of sensors, so I didn’t have to fix the flows, just look for the groups
  • the group app did recognize the sensors after reconnecting

I came across an interesting article why our zigbee network seems to go crazy after the 5.0.0 update. It’s due to a change in the network key that was in the current Zigbee devices. Hope this is useful for those interested.

https://yougottahackthat.com/blog/1260/athom-homey-security-static-and-well-known-keys-cve-2020-28952

Cheers,

3 Likes

The “well-known” key apparently only gets generated when you do a Zigbee reset. My Homey, running 5.0.4, is still using the known key: