Zigbee Mesh & Ikea Tradfri


im new to homey since a few weeks and already using some zigbee devices. Sometimes some devices are not reachable, so I decided to add 3 Ikea Tradfri Zigbee Repeaters yesterday. Pairing was successfull and they are in my list.

Reading the forum I followed the hints and turned off my home for about 1 hour to create a new mesh network after installing the Ikea Tradfri Repeaters.
Today, almost 20 hours later, almost all devices are still connected directly to Homey and no device uses an Ikea Tradfri Repeater. For example all pool-plugs (Osram) are far away from homey with an Ikea Tradfri Repeater between - but they don’t go through the Repeater :frowning:
What can I do, to improve my mesh network (beside rebooting homey)?

Attached you can see the zigbee routes from the developers website.

Thank you!
BR Mario

The firmware < 5.0 causes problems with Zigbee. Therefore, firmware version 5.0 (experimental) was released this week.
I have included 2 Tradfri Repeaters and 2 Kadrilj blinds as an experiment. The blinds run over the repeaters.

But before you update to v5.0 you should inform yourself first, because at the moment not all apps are adapted to the new firmware.

Oh I understand.
I was already wondering, why my Osram Plugs don’t act as a repeater - now its clear.
Thank you for the information.

I m running 5.0 for 2 days now and I can confirm that the Zigbee works much better. For me, the lamps were always directly connected to Homey.

With 5.0 a very nice mesh network is created

So just a little patience

*Node 10 is a repeater

1 Like

Geez, that suggests that the previous firmwares used the Zigbee cluster tree topology, not the mesh topology. That would be a pretty silly oversight :scream:

Nice to hear (read)!

What does “receive when idle” and “interview” mean?. Those options are new, I think?

I don’t know if this is the case for all zigbee divices.
I only have Ikea on zigbee, all other devices I have on z-wave

I can only confirm it for the Ikea lamps

I do not know yet

It seems that information is then being read from the device. This will then be displayed in a popup

The controller (Homey) sets the network topology, and that’s about all it can do. So if the mesh has improved considerably with v5, the only reason that I can think of is that the topology was changed (the coordinator cannot “tell” devices that they should connect to a particular device; also, the range of the coordinator cannot be magically improved). Which would (partially) explain why Zigbee had so much issues before, because with a cluster tree topology, router devices can only connect to the coordinator, not to other router devices (as with a real mesh).

But I’m guessing here, I don’t have any Zigbee devices connected to my Homey so cannot test myself.

1 Like

sounds plausible

I am still running 4.2.0 and my experience is that devices end up using routing as long as you pair devices using a router. So do not pair them next to Homey but at their actual intended location (or even a bit further away to make sure they need to use a router to pair.)
I even used some Aluminumfoil to make sure the new device could not ‘see’ Homey directly :shushing_face: .
I have around 10 devices that connect via a router in my current Zigbee network. Mostly via Ikea Tradfri repeaters.
In all cases it is however limited to 1 hub (= using one repeater to get to Homey) so I wouldn’t call it a true mesh.