Zigbee device Interview on Homey Bridge does not work

I also have a Homey bridge and a homey 2023 (early). With the same tools, the interview goes well on the Pro, while on the bridge it gives a Time out after (quite a lot of) time. The devices themselves are recognized by the bridge as generic zigbbe devices and can be controlled.
Can somebody help me? (The pro is in my weekend house, in the countryside)

Some devices need to be woken up before interviewing, and need to be kept awake during it.

1 Like

Also with the same type of devices? I guess what @robertklep says and you interview a Zigbee Router type device on the Homey Pro and a (Battery) End-Device on the Bridge.

That would make your Topic title not true … :wink:

Specifically, I took the same device to the countryside where the interview took place on PRO. However, it is not completed before or after it on the Bridge.

1 Like

Let’s stop guessing,

What device is it, is it a Battery Powered or Mains Powered / Routing device?

IMO it should work on both Homey Pro and the Homey Bridge the same.

I tried both battery and mains powered devices. None of them gives an answer to bridge, while to pro either one of them gives an answer.

Just tested and indeed, it doesn’t work (anymore)

What is your Homey Bridge Firmware and Zigbee Firmware reported?

Please create a Support Request here: Support | Homey

Bridge fw:
Where can I see the Zigbee version?

I wrote to support yesterday, but the answer is expected in 2-3 weeks.
This makes app development a bit difficult… :frowning_face:

1 Like

+1 here - glad I’m not crazy :upside_down_face:
Reported with support staff on Jan 31, when this had been going on for a couple of weeks already, but no response yet. Request#: 117105. Gave it a last effort today before looking into alternatives when this post popped-up.

Interview timing out consistently on powered/routing devices. Tried with and without the manufacturers app installed (Lidl Home). And I need the interview to unlock all features of the device (warmth, colours), so with this not working I’d have to start looking for a different coordinator.

homeyVersion: 10.1.0
region: prod-eucentral1-001
homeyModelId: cloud
Firmware Version: 2.6.3-20231124
(Homey app lists firmware as 86 )
Diagnostics report code: 4B103669 (at the time)

Is there an update on the situation or things you want us to test, /u/Dijker?

How do you think that’ll work?

Fair question. I’m not sure on the specifics of how/why it works, but it does - and it was the go-to tip when I researched a solution to that particular issue. Sorry, don’t have the time to try and find the sources (will edit-in later).

For now, I think it’s more important to keep the focus on why interviewing stopped working altogether on the Homey Bridge.

Just an update that Homey support has reached out to me, mentioning that “There is a chance this was a corruption in the firmware on the Zigbee chip”. They have requested I share an admin invite with them so they can attempt to flash the Homey Bridge.
Invite was sent, awaiting response and I’ll report back here if there is any progress.

1 Like

Hi all, update from Athom support:

I have now reproduced this issue in our office with both Basic Zigbee devices and devices that use official drivers. So this seems to be a bug in the software somewhere. I have now forwarded the issue towards the development team with a clear explanation on how to reproduce the issue. I can’t give you any guarantees on when your issue will be found and solved, but please know that it will be placed in the right hands and will be investigated further.


So far it seems all Homey Bridges have this since this bug seems to be in the software/firmware since no Homey Bridge that was tested was able to do this.

1 Like

Just coincidently, Athom rolled out a firmware update with Zigbee changes for the Bridge only recently. I guess this issue slipped passed the QA department :man_shrugging:t3:

They gave me practically the same answer.

1 Like

Good news about the interviewing issue:

(the issue) has been found and will be resolved soon, it’s currently being tested on the test cluster and since this is a server sided update it might get pushed to stable relatively soon.



Nothing so far. Keeping an eye on releases here:

Still nothing :frowning:
But I guess relatively soon is… relative

it’s a joke.

In the meantime it’s working now for me, but needs 1-2 minutes to get the result.
Before I got a result much faster.