"Homey Bridge, borderline unusable product."

Hello everyone,

I find myself in a bit of a dilemma. I’m a big fan of the Homey ecosystem and was eager for it to be a great addition to my smart home setup. I appreciate the user-friendly interface and the intuitive nature of the flows.

I opted for the Homey Bridge, thinking it would suffice for my small apartment equipped with 15 connected Zigbee devices and a Wi-Fi smart plug. Please refer to the attached photo for Zigbee information.

However, I’ve been encountering significant delays with my devices, ranging from 20 seconds to 2 minutes. At times, the bridge even times out, rendering it inactive. The bridge is centrally located in my apartment, approximately 2 meters from my router.

Prior to acquiring the Homey Bridge, I used Home Assistant, which functioned flawlessly. I made the switch to Homey for the user experience, but the excessive delays are rendering the product nearly unusable. Is there anyone familiar with a fix for this issue?

Additionally, I’ve noticed remarkably high ping rates for the data centers. I reside in Denmark, and my ping to the Stockholm data center is around 216ms, which is quite concerning.

Any insights or solutions would be greatly appreciated.

First of all, welcome to the Homey Community!

To make sure you are aware of the forum rules, please read the Welcome to the forum! post here.

I just wonder why there aren’t routes in my Zigbee overview. Your overview is from Homey Developer Tools ?

Could it be because I have HP23 and you have Homey cloud with Homey bridge?

Yes, routes aren’t available for the HP23.


I’ve just decided to go for the Homey Pro 2023, and I sincerely hope it lives up to my expectations. Fingers crossed I won’t be disappointed! I’m in the process of returning the Homey Bridge to get a refund, as I believe the latency issue with the Stockholm server is causing performance problems.

I’m curious, does the Homey Pro operate locally without the need to communicate with the Homey servers?

Yes. But keep in mind that some apps communicate not directly to your devices but via the cloudscape of that device. For example NetAtmo and Evohome. So for every device with its own dedicated bridge and cloudaccount.

I use the bridge with the cloud environment for 6 months without any issue. My environment is hosted at aws frankfurt, latency is about 6ms.
I use zwave,zigbee,kaku,various cloud services.
About 250 flows, 80 devices,15 apps

Of course, local lan based devices are not direct accessible but i think that there are a lot of devices possible. Also devices capable of sending webhooks will work with the bridge (cloud)

I used to have hass linked to homey bridge, but my hass was suffering from issues, so stopped with that.

Just make sure that antenna position is ok, i mounted the bridge vertically, and that helped a lot.

the internet provider must be ok, not generating too much latency. I put the bridge on a separate vlan, excessive broadcast in your network can cause issues (iptv without igmp snooping, dodgy applications,bad wifi, do not use bandsteering, fix on 1 AP

I was sniffing the traffic from the bridge, and it is a continuous stream of encrypted https packets, with low bandwidth.
But timed critical commands pulled of the homey cloud by the bridge cannot handle high latency. More then 200ms is way too much

Most people, including Athom, will say that Homey Pro runs fully local, but it doesn’t. For authentication and some other tasks, cloud access is required, and it happens quite often that this fails for some reason and you get a “Homey Offline” error in the app or on the website (when in fact they can still ping their Homey on the local network just fine).

I use homey app on an ipad, and i found out that when my mobile security (trend micro) is enabled, the homey app is not able to access my homeys, it shows ‘offline’. When i disable mobile security, then it works normally, my homeys show up in the app.

Still need to find out why it shows this behaviour , (other apps and services are not affected) maybe mobile security thinks its spoofed or something.

Does it protect against [Technical] The pros and cons of DNS Rebinding protection

1 Like

Hi, as I am a Homey Bridge / Homey Cloud user like you, I would like to know if your system still works as nicely as you describe, during the last week or so. My own setup worked reasonably well up till last week. Now it failes to start virtually all of the time based flows, about half of the webhook based flows, plus many flows based on device events. When I do webhook calls, I see latencies up to 600 msec (Frankfurt server). I have submitted a support request, but Athom will need 3 weeks to respond.

i have no issues, flows work, webhooks fire and receive, zwave,kaku,zigbee work
i am also on frankfurt.
few weeks ago i had also some issues with auto flows, but a restart of the bridge fixed it.

1 Like

net latency gemeten

Sounds good. What kind of a restart did you do? Unplug for a while, maybe also remove from Devices in the app? Or a full reset to factory defaults?

Just unplug, wait a minute, plug back in.
Also check wifi, do not enable 5ghz,roaming/mesh for the bridge, fix to 1 ap.

Btw, on my network at home, i put it in a separate vlan , and on return traffic from the cloud, i put qos to have that traffic with more prio then the gamers & downloaders over here

That’s odd, and I don’t understand how that could solve it.
Flows run in the cloud, in fact all of Homey cloud runs in the Athom cloud…
The bridge is nothing more than a piece of hardware to enable local protocols like zigbee.


Removing the bridge from Homey cloud already resets it to factory settings.
But it has nothing to do with the time issues of your flows.
Only the device events, of devices connected per bridge, could be influenced and delayed for all kinds of reasons.
Homey cloud itself can only be restarted, nothing more.
Are you sure nothing’s changed with your (W)LAN network(s)? Internet connection in general?


That’s not what they say. Expect it to take 2 -3 weeks it says. Often you’ll get a response sooner than that.

Well, if the bridge is not listening to the cloud anymore, then the effect on flows which switch things via the bridge is like the flows are not running, And maybe the cloud software checks if the bridge is correctly connected before it runs flows.

No, nothing has changed in my (W)LAN settings, or my internet connection. I also found it odd that powering off the Homey Bridge should restore the starting of flows, but I tried it and I am actually seeing some improvement… although that might be accidental.

It still misses some flows, like webhook initiated ones. I repeat them 3 times now, with a few minutes in between. Often they only work the second or third time. Flows that start other flows after a programmed delay are often missed as well.

In discussing this issue with Athom support we came to the conclusion that too many flows were started (by devices triggering these flows). After disabling a couple of my flows that were relevant in summer only, the remainder of my flows started working reliably again. If I understand things well, the maximum number of flows that can be started within a minute is 30. Trying to start more than that results in new flows not starting, without any warning. Only when you repeat a missed flow manually, you sometimes see the error “Flow rate limited at 30 per 60 seconds”. I guess I will have to learn to live with this limitation.